TM 1000 telemetry on a DX9

  • I have a power box competition SRS with a TM1000 connected- in the telemetry menu of the DX9 the powerbox option is selected
    On the power box menu the telemetry option says( spectrum telemetry)
    I am programming the radio with plane next to me on the bench and this is the scenario:
    1) I am receiving 3K to 4K frame losses!
    2) up to 45 holds !
    3)Voice commands are not correct as they are stating decimal points in wrong values of capacity and voltage
    4) The voltage and capacity screen readout the correct values


    thanks for all you do!

  • Hello,


    you need to do following to get correct flight log data: Connect the telemetry output of the Competition SRS with this lead and the TM1000 data port. You need to remove RX2 satellite


    If you don´t need receiver data, the values for capacitiy and voltage must come without this wire and removing RX2. You may send me a picture of your wiring. Also take care that all satellites are DSMX and your binding in the PowerBox is also with DSMX

  • Hello,


    no need to rebind. I don´t know the problem... it should work at once. You just have to bring the PowerBox in binding mode (Satellites blinking). Then press TM1000 button and connect it to power at the same time. Now TM1000 and satellites are blinking. Press binding button at the transmitter and turn it on.

  • Richard.....i have rebound the power box with sat # 2 removed and it seems like all frame and holds are a 0 now
    My question is : do I only use 3 sattelites now with telemetry?
    Why is this?

  • Hello,


    this is because serial controller input now is used for telemetry output, no longer for input.
    If you remove the data telemetry you can use the RX2, but you cannot see reciever data. Voltage and capacity are comming with the 4-pole wire, independend on RX2/data usage