Orientierung IGyro

  • Hallo,


    nachdem die Verkabelung sowie Servozuordnung und Matching fertig gestellt ist, wollte ich heute die Einrichtung des integrierten IGyro vornehmen. Die automatische Erkennung der Einbaulage bekomme ich bzw. Die Royal aber leider nicht hin.
    Bei Heck links/rechts bewegt sich das Seitenruder schön mit und der Fortschrittbalken im Display ändert sich je weiter das Heck bewegt wird, soweit ok.
    Beim Pkt. Heck hoch/runter bewegen sich die Ruder nur marginal, der Fortschrittbalken füllt sich nur zögerlich.
    Beim späteren Test werden die Höhenruder als Querruder vom IGyro angesprochen.


    Wird der Rumpf beim Pkt. hoch/runter auf quer geneigt füllt sich die Balkenanzeige sofort :shock:


    Firmware habe ich vor der Einrichtung auf den aktuellsten Stand gebracht.
    Die Box ist quer eingebaut, d.h. die Servoports zeigen auf die Fläche.


    Wo liegt der Fehler ?
    Viele Grüße, Thomas

  • Nachtrag:


    Bewege ich das Modell beim Pkt. Hoch/Runter auf Quer füllt sich die Balkenanzeige. Der Höhensensor funktioniert wohl da sich später in dieser falschen Orientierungseinstellung bei Heck hoch/runter das Querruder bewegt.

  • Hallo Thomas,


    Damit der iGyro merkt welche Achse er messen soll, muss das Heck einmal relativ schnell angehoben bzw. abgesenkt werden. Wenn der iGyro dann erkannt hat, welche Achse die Höhgenachse ist, füllt sich auch der Balken. Genauso muss man dann auch mit dem Seiteruder verfahren.

  • Hallo Alexander,


    sorry aber die Querneigung und Heck rechts/links wird in der Balkenanzeige direkt quittiert, nur bei Heck hoch/runter ändert sich nichts an der Anzeige. Das funktioniert auch nicht wenn das Heck schnell hoch/runter bewegt wird.

  • Hmmm, igendwie scheine ich undeutlich zu schreiben ....


    Die Höhenruderachse lässt sich ja nicht einstellen, das ist doch genau mein Problem. Bei diesem Pkt. ist scheinbar nur die Querachse aktiv, nur eine Bewegung auf Quer wird registriert.

  • In dem Fall das ich die Höhenruderachse per Querneigung einstelle ... ja, ist ja auch logisch


    Bei der Einstellung der Höhenruderachse scheint die Gyrohoch und Seitenruderachse ausgeschaltet, nur die Querneigung wird registriert.

  • "ThLehmann" wrote:

    Bewege ich das Modell beim Pkt. Hoch/Runter auf Quer füllt sich die Balkenanzeige. Der Höhensensor funktioniert wohl da sich später in dieser falschen Orientierungseinstellung bei Heck hoch/runter das Querruder bewegt.


    "ThLehmann" wrote:

    Die Höhenruderachse lässt sich ja nicht einstellen, das ist doch genau mein Problem. Bei diesem Pkt. ist scheinbar nur die Querachse aktiv, nur eine Bewegung auf Quer wird registriert.


    "ThLehmann" wrote:

    Bei der Einstellung der Höhenruderachse scheint die Gyrohoch und Seitenruderachse ausgeschaltet, nur die Querneigung wird registriert.



    und nu ?

  • Hallo,


    wir haben das mit Ihrer Einbaulage nochmal hier getestet- geht einwandfrei. Der Sensor funktioniert ja offensichtlich. Ich denke die Achse schaltet nur nicht um- Sie müssen einmal mit einem kleinen Ruck die Achse zum Umschalten zwingen.

  • das mit dem "kleinen Ruck" habe ich anhand der Empfehlung von Alexander ja bereits mehrfach probiert, ohne Erfolg.


    Die Installation der Box wurde mit der V14 (evt auch V13 mit Update auf V14) vorgenommen. Vermutlich habe ich dort auch mal die Orientierung (falsch) eingestellt. Habe zuerst alle Servozuordnungen, Wege, Richtungen und Matching konfiguriert. Nachdem das alles fertig war jetzt Update auf V15 und der Versuch die Orientierung mit dem Setupassisten zu machen, mit dem hier geschilderten Problem das nur noch die Querachse im Fortschrittbalken angezeigt wird.


    Was mich auch wundert ist das bei der Orientierungseinstellung der Hochachse nur Querneigung und bei Einstellung der Seitenruderachse nur Heck links/rechts in der Balkenanzeige eine Änderung bewirkt. Meines Erachtens sollte doch jede Achsänderung angezeigt werden ?

  • Hallo,


    es kann ja immer nur eine Achse am Balken dargestellt werden. Mit dem Ruck (geht auch mit viel Auslenkung) schaltet die Achse um, dann wird diese dargestellt. Beim Höhenruder kann man alle 3 Achsen abbilden, beim Seitenruder einstellen dann nur noch die beiden verbliebenen.


    Wenn wir da jetzt keine Lösung finden, wäre es wohl das Beste Sie schicken uns die Weiche her.

  • So, habe es jetzt geschafft :oops:
    Mit zwei drei extrem schnellen Ruck am Heck konnte die Orientierung "gelöst" werden und die Höhenruderachse korrekt eingestellt werden. Ein "normal" schnelles Bewegen wie vorher praktiziert war wohl nicht ausreichend.
    Ich gehe jetzt fest davon aus die Orientierung vorher mal falsch eingestellt zu haben. Was ich allerdings nicht verstehe ist der Grund für dieses umständliche "Lösen". In dem Fall das die Orientierung neu eingelernt werden soll können mE doch alle drei Bewegungsrichtungen freigegeben werden. Man kommt ja eh nur weiter wenn die Achse dedektiert wurde.


    Naja, jedenfalls bin ich froh das es jetzt funktioniert, Danke.
    Gruß, Thomas

  • Hello Richard,
    I am having the same issue with defining the installed orientation of the Royal SRS. The SRS is mounted sideways in the plane. If I raise or lower the tail of the plane nothing lights up in the bar. It does not matter how fast I move the plane. I even took the wings off and rested the wing spar on 2 saw horses then rotated the plane 360 degrees still nothing. The only way the bar lights up is if I roll the plane as if it is stuck on the aileron axis. I have reset the SRS 3 times now to make sure I went through it perfectly.
    Do you have any suggestions?
    Is there a way to set it the old way like the manual states and the older model Royals where done?

  • Problem solved!! Today I removed the SRS from the airplane and went through the setup with it on the bench. It registered right away. Where it is mounted in the plane must not have allowed for a swift movement of the axis.


    Thanks Cris Finck