Multiple problems: inconsistent binding, inconsistent control, some chattering

  • Hi there - Evolution Spektrum is not binding consistently, binds and powers servo but no servo movement with control inputs, binds and powers servo but control input chatters servos. We replicated this with two different Dx9 transmitters. Obviously don't want to fly the unit but it is relatively new (one year). Any thoughts on what to do? Thanks.

  • Thanks Richard. Sometimes the satellites are blinking, other times they are not. It's the inconsistency that's worrying. We've tried with different combinations of satellites just to rule out a satellite problem. We're using Savox 1270TGs all around, again some of the time they work fine. The chatter is interesting - in neutral stick positions the servos are powered and quiet, but once we move the sticks, it's a small up-and-down pulsing to whichever servo you're controlling. In our tests, this only happened twice; the more predominant situation is powered servos but no movement from any inputs.


    Let me know what you think.

  • I looked around but couldn't find return/service instructions. Can you please point me in the right direction? I also happen to be in France next week so am thinking it'll be easier to send from there. Thanks. (BTW - I really like the new forum software)

  • Hi Kranjams,


    I`ve received your PowerBox Evolution Spektrum for service today.

    I did a lot of testing with varoius settings of my DX18 but was not able to reproduce the issues you had.

    I tested binding with DSMX Mode on 22ms an 11ms fraterate, also tested with DSM2 mode. All in all no problems.

    Also after multiple power cycles, I was not able to get a fail... no chattering, no loss of servo control, no binding issues.

    Can you give me a overview of your setup?