Problem after update

  • I just did the update from 5 to 7. Everything was fine. Then I plugged the GPS into the Bluetooth which I had plugged in to the tele port and went to PC Control and I believe it said updating from 10 to 11. It said it was updated sucessfully so I unplug power from the Mercury as I was doing it out of the jet so I didn't use the switch to turn it off. Then I thought I would check the telecom adapter and when I powered up the mercury the blue lights come on inside the Mercury but nothing on the display. The GPS light is not on also. I plugged my two futaba 7008 receivers in and they got the green lights on them. When I plug a servo in the Aileron port on the Mercury nothing happens. Any thoughts on what I should do?


    Thanks

  • I connected my USB and brought up PowerBox Terminal V 2.0.4. I don't see a rescue mode. The things I tried kept saying to put the Mercury into PC-Mode which I can't do since the display is blank. It also kept saying device not found since I couldn't put it in PC-Mode. I also looked in FAQ's but didn't see any info on how to do it.

  • Oh- so you tried to update the GPS over the Mercury? I think this crashed the update.

    Normally you just connect after a crashed update the Mecrury to the USB (TELE post). Then turn it on and start the Terminal program. Press "Update". It should find a unknown device. You have to select the correct file.