Mercury SRS not working after Bluecom update

  • Several months ago I purchased a New Mercury SRS from Chief Aircraft RC. When it arrived I immediately connected (2) New Spektrum 9030T receivers with (4) satellites, (2) New 2.5 Pro power box batteries, Spark switch and 6 servos. It took less than 20 minutes to read the book, use the Set-up assist and get the Mercury SRS working. All servo worked to include PB Spark Switch. I also purchased the PB Bluecom for ensuring updates.

    Afterwards I connected the Bluecom and let the update run. I disconnected the components and placed them back in the original boxes. I’m now ready to install Radio gear in the aircraft and cannot get the Mercury SRS to link up to the either 9030T receivers. As stand-alone the receivers will connect immediately with the Spektrum DX8 radio. I’ve tried both DSM2 and DSMX set-ups. The Mercury SRS does not recognize either set-up and will not link with a radio. The set assist will not recognize the FM switch.

    I ordered the PB USB connector to improve download speed thinking there may be a corrupt file after the update. The USB part is now on backorder and I cannot use the PB Mercury.

    When I tried to bind the receivers the satellites Quick Flash and appear to bind. The two receivers do quick flash during binding however go into a slow flash and do not bind.

    This is my first PowerBox systems set-up and a little concerned with reliability. I feel like the problem started with the recent update to V8 however I’m not experience enough with Mercury SRS. So without the USB I cannot tried the recommendations I’ve read on the PBS forum concerning the Bluecom.

    Any suggestions.

    Thank you,

  • Okay, it's link to radio however servo's not working? When I plug servo in, it centers. The Control/Sticks on the radio does not work?

    Why not use receivers?

    Is there still redundancy?


    ***I did figure out how to get the servos working.

  • Okay, it's link to radio however servo's not working? When I plug servo in, it centers. The Control/Sticks on the radio does not work?

    Why not use receivers?

    Is there still redundancy?


    ***I did figure out how to get the servos working.



    for the servos to work you must run the setup assitence on the powerbox, you need to do that i have the same problem.