Royal SRS Gyro Sensor Failure

  • Dear Richard,

    I have been a Powerbox user for a while, all my models have PB systems in them. I have Royal SRS in one of my other model and it has worked great eversince. I have iGyro3e in all the other models. In late July'18 (2.5 months ago) I purchased a New Royal SRS from your Australian dealer - Desert Aircraft Australia. Just a few weeks ago I installed it in my SM Hawk100 that I have almost completed building, the model has not been flown as waiting for the turbine. The systems was recently installed in the Hawk and except for the door sequencer everything else including Gyro was setup as per the manual. Everything has been working fine until this morning, when on powering the Royal, the screen showed ' Gyro Sensor Init failed, Restart Powerbox'. On subsequent restarts (tried several times), the same error continued to appear and on the last couple of restarts, the 'init failure' error does not appear however the screen seems to be stuck on ' Powerbox Logo'. None of the switches on the switch box seems to make any difference. All the control surfaces on the model are working fine and move as per the transmitter input however the PB screen is stuck on the PB Logo (previously the screen remained stuck on the Gyro init failure previously and now on the PB Logo) but I cannot access the Royal SRS menu. The Royal as v18.9 software. I use Jeti DS 16, have two RSAT 2 connected.


    This whole thing is completely bizarre, the Royal has worked flawlessly until last night, last shut down was as per normal. Nothing has been changed or added to the system since last night, fail to understand why all of a sudden the Gyro Init failure happened and now the SRS is stuck on the PB Logo and SRS menu is in accessible.


    This is really disappointing to see such a critical error appear and I am really worried about the Royal SRS's long term reliability and functionality going forward even if by a miracle this error no longer appears. I do not intend to operate this model until such time I am convinced this matter has been effectively resolved.


    Given that this unit has been purchased on the 27th July 2018 (can provide a copy of the invoice if required), I assume there is some warranty support that can help sort this issue out. Can you please help me resolve this error.


    Many Thanks


    Amit

  • Hello,


    the answer is: your gyro sensor has a failure - to prevent flying with that there is an error message and no signal output. So I can understand that you are disappointed, but you don´t have to worry about the reliability of the Royal. A sensor failure is very unlikely and happens in 1 of 1000 units. Even if it happens during flight, the software bypasses the sensor so you are not out of control!


    We simply exchange the sensor or the complete PowerBox and you are fine - of course this is under warranty! Please contact your dealer what he wants to do.

  • Dear Richard,

    Thank you for your prompt reply. Given the odds of 1 in 1000 units having this failure is reassuring in some ways but equally concerning given that this particular Royal SRS happens to be that 1 in 1000 unit. I would rather not venture further with this unit by having the sensor replaced, the fact that this SRS unit had one of its integral part of the system show a failure I am afraid I cannot bring myself to risking my model. Given that its under warranty and I have bought it a short while back, I would rather that the complete PB Royal be replaced than having it sent to the factory. I will speak to the PB Dealer from whom I have always purchased my PB units and request him to replace the unit for me with a new one, you can then have this unit replaced for them so they are not stuck with a faulty Royal SRS unit.


    Thank you for your assistance and your great service.


    Regards