Powerpak 2,5 x 2 PRO problem

  • Hi Richard,


    See what happened last night to one of my Powerpak batteries. It's overheating at the front and now I cannot charge it anymore it's completely discharged.



    Can I fix it alone here in Dubai? Why could this happen in such expensive batteries;(;(?


    Thanks, Tassos

  • Hello,


    you mean it gets warm when just lying arround? This is because of the self storage function - but the voltage is too low. This function should be disabled already.

    The red Led has two functions: red when charger is connected and charging. Red when there is no charger and the battery is empty.


    Nevertheless: it must not get empty overnight - there is something wrong. Who is your dealer?

  • Hi Richard,


    Definitely something wrong. Yes it got hot laying around and it now discharged down to 0 today. Then I'm connecting the charger and the battery is again getting hot at the front and the red light is not coming on.


    I bought these from der-schweighofer if I remember correctly or from Jautsch. I cannot tell because I got 2 from Jautsch and 2 from Schweighofer.


    It is too expensive for me to send it back from Dubai to you anyway (postage is around 40Euros) I would prefer to fix it here and also would take a long time to repair and it is flying season here.


    Is there any other way if I open the pack to repair locally? But if the battery is dead it's dead also - cannot revive Lipo batteries from 0 Voltage.


    Thanks, Tassos

  • Hi Richard,


    I have another 2 batteries that have become faulty and are not charging any more but also not auto-discharging, the red light is not working at all.


    They're stuck at 7.9V and 7.4V. Normally these batteries should charge at any voltage correct? But they're not starting to charge.


    I have 4 batteries - 3 have become faulty. Is there something I'm doing wrong? I just feed them with 12V.


    Serial Numbers: 256191, 258651, 256196.


    Very weird and there's nothing I can do about it. They're not charging at all.


    And I cannot fly :cursing::cursing::cursing: and very frustrated and sad.


    Tassos

  • Hello,

    if they do not charge there must be another problem which has nothing to do with the self discharing. The chargers in the PowerPaks are the same type we use now for over 10 years. To be honest I cannot remember when we had the last defective charger... You can send us the batteries for a check.


    Did you also try to charge them with the mains supply?

  • Hello,


    do you have the power supply from us?

    The problem with a powersupply like yours is oftne that in the moment of turning it on or off there are voltage bursts. Maybe if you have the batteries already connected and then turn on the powersupply there is a desroying burst. I have no other explanation because the charger in the batteries makes normally no problems when using our power supply!

  • Hi Richard,


    No, only supply 12V from the Graupner charger and never connect to charge before the charger is on and stable. But I can buy your charger as well.


    Anyway, I have sent the batteries for you to open and review the problem. Should arrive to you in 10-15 days.


    Happy New Year


    Thanks, Tassos

  • Thanks Richard,


    I have another 2 batteries x 2.5PRO and another 3 batteries x 5.0PRO which are working ok. What to do with those batteries? Send them to you for software upgrade as well?


    Thanks, Tassos

  • Thanks Richard,


    No I would like to keep the discharging effect. What does the battlife guard do and how should I use it? Shall I use it in the batteries I already have or only the ones you repaired? Please let me know if the repaired batteries are now ready and been sent back to me.


    Thanks, Tassos