abua/sbus2

  • Thank you for your quick reply. The Mercury is absolutly AWSOME 👍 with everything going thru sbus2 ports. However I'd like to use sbus ports for servos and one sbus2 port for telemetry and I can't seem to get it to work. I changed the mode on borh receivers according to Futaba to be ch1-7 and sbus port(mode B) and the servos work but the sbus2 teleconverter port on Rx#1 doesn't show any data? I did make sure to plug the futaba end to the sbus2 port and the powerbox side to the powerbox telemetry output.

  • I did it. I got it working and this is how; 1st after linking to the receivers to the radio(16/18MZ) set the mode for Rx #1 to "B" then set Rx #2 to mode "D". Don't set both to "B"!. Then plug Rx #1 to Mercury in Rx slot #1and the other to slot #2 Both receivers should now output on both sbus & sbus2 as well as telemetry data via sbus2 port on Rx #1. And as Richard said make sure to save the mode selection as per Futaba instruction manual. Again thank you for your quick response and to the whole powerbox team for a excellent product. 👍

  • don't seems so easy...

    does it need two teleconverters or juste one is enough?

    Is it ok to have

    - One RX on sbus 1 without teleconverter

    - The other RX on sbus2 with teleconverter?


    What is the safest config?


    Thanks

  • you can have one or 2 receivers. HOWEVER only the receiver plugged in to Rx1 on Mercury can transmit DATA via the teleconverter. Plug the teleconverter into the telemetry port use a Y lead and both Rx1 and teleconverter go to sbus2 on the primary receiver. Or what I did to eliminate the Y lead was to use sbus ports out and just the teleconverter going into the sbus2 port on primary receiver.