Posts by dlpeirce

    Eliminating the problem "normally" is still a problem. I really like the Mercury but it will only take one issue like I have experienced in the wrong place, low pass, landing etc. and a very expensive model will be destroyed due to the Mercury malfunctioning from turbine noise. Is the Royal not affected due to its larger size than the Mercury?

    Richard,

    I thought I saw a post somewhere on this forum that referenced a V2 Mercury SRS that has been redesigned so that it is not subject to the turbine noise problem therefore not needing the foam cover. Is this true that there is a later version of the Mercury SRS?

    Thank you,

    Darin

    Richard,

    I am the Mercury user who started this thread. I have the same unit installed in a brand new Elite Aerosports Havoc and cannot turn on the gyro due to this issue. How do I get a cover for my Mercury? It is not available as an accessory. I know you have offered them to owners of Mercury's, how do I get one for my unit?

    Thank you,

    Darin

    Hello Richard-


    I wanted to check with you on the Mercury I sent to you for diagnosis pertaining to the incident described at the beginning of this thread. Just wondering when I might expect to get it back and what you may have found.


    Thank you-
    Darin

    Richard-
    Thank you for your correspondence. I have returned my Mercury as you suggested which I believe you should have received by now. I appreciate you working with me to help solve the problem. It is not my intent to point fingers at Powerbox rather just solve the issue whether it be a radio setup problem or something else. I just want to be able to use all the great features of the Mercury with the 18MZ. Thank you again for the help and I look forward to hear what you find or suggest.
    Darin

    These two incidents sound far too similar to not be related in some way. I must say that Powerbox has asked that I send my unit back so they can inspect it, which I have done. I appreciate their support and willingness to try and solve the problem.

    This does sound like the same issue that I had with my Mercury and 18MZ. We did fly with gyro turned on for a couple minutes before the lockout incident. I believe these situations are too similar to not be related to some issue with powerbox and Futaba 18MZ. I had it happen on two separate flights using two different sets of receivers. First incident was using 6303's second incident using 7003's on mode 2.

    Richard,
    I have been flying a Pari-Tech Natrix since September of this year logging 18 flights using the Mercury SRS with a Futaba 18MZ and 6303SB receivers. I was attending the Best in the West Jet Rally last week Oct. 4-9 and made approximately 10 flights on the plane. At this point I got help from Ali Machincy to activate the IGyro in the Mercury and with his help used the setup assistant and then the test fly assistant. Ali offered to fly the plane on the first flight to adjust the gain and make certain everything was functioning normally. After about two minutes of flight and dialing up the gain slowly the plane made a hard 1/4 roll before Ali regained control. He flew for a few more seconds and the plane made two fast full rolls to the right. He switched off the gyro and immediately landed without further incident. I then had Trond Hammerstad look at the plane and he suggested that I should be using 7003SB recievers rather than the 6303's I had in the plane albeit I had made nearly 30 flights on the plane without incident. I completely trust Trond's advice and got two new 7003SB receivers from a fellow Team Futaba pilot. Trond and I installed the two new receivers and then Ali flew the plane again. This flight had the same result with the plane losing control after the gyro switched on and the gain began to be dialed up so Ali landed again with the gyro off. I flew the plane the rest of the event with the gyro turned off and had no further incident, the radio functioned normally.


    Trond and Ali suggested I ask you for some help and said I could tell you that they helped me and could not figure out what was going on. What could be the cause of this issue? I am afraid to turn the gyro on to finish the gain adjustment and fly it with the gyro function. I love the Mercury SRS but want to be able to use all its function with my 18MZ.
    Thank you,
    Darin

    I have a a Mercury SRS and cannot figure out how to make simple gear functions work through the powerbox. The gear are Pari-Tech electric running through a XiCoy controller. I used the setup assistant to program all other functions but cannot figure out how to make simple gear functions work. The plane is a Pari-Tech Natrix so no gear doors just retraction, steering and brakes. The only gear functions I can see in the PB programming are for door sequencing. What am I missing? I have tried going to a Direct channel but then I cannot input map it. The only menu choices for given by Powerbox are door sequencing and I can't figure out how to use that to program the simple functions for gear. Just trying to make the gear go up and down, steer when they are down and make the brakes work. I am using a Futaba 18MZ. Any advice or suggestions are appreciated
    Darin