Posts by Arie

    Richard,

    I got tired tying to get the telemetry to work. I will try again this weekend. I will go over your instructions again not to miss any step, I wish you can make a short video for all of us w Futaba radios instead of the going back and forth here.


    Thx

    On the initial set of the teleconvertor did you choose other futaba trasmeter option?

    And how did you change the sluts? 17-32?

    Did it display powerbox ? Or Reg number?

    Hello,

    I have similar issue,no telemetry on my futaba 18SZ

    Updated my murcury Srs from V5 to V7 via blue Com. Then download v3 on the teleconvertor and set it to T18 and-connected to the Mercury/reciver after registering it on the trans and got powerbox massage on many of the telemetry sensors. But still no telemetry.

    Need assistance.


    Thx

    Thanks Johnny,

    In fact I went and did a factory reset started fresh. Went through the all set up and General set up all controls working as desired. However when switching to mode 2 or 3 no correction are not made by the gyro. I think I am missing something.

    Thanks in advance for your help

    Hi Richard,

    1.How do I get to the menu at page 23 of the Manuel?

    2.How can I test the gyro on the ground?to insure that it works correctly

    3.Do I need to update V5 to current version?

    Second page ( setup & Test fly under one option)

    SETUP ASSISTANT

    TEST FLY ASSISTANT


    When i choose that option next menu is


    CAUTION RESET

    SURE

    NO YES


    please note when i move the model to check if the gyro function the controls surfaces don't correct themselves

    but during setup all surfares responded correctly

    Hi Richard.

    When I went back to main menu set up assistance/test fly assistance, it resets all the outputs/control flight. It does not take me to the the screen that shows on Page 23 unless I'm doing something wrong during the process. How do I get to the menu screen that shows on Page 23?

    My 2nd question is, how do I check that the Gyro is functioning right when I am in Flight mode 1 and 2?

    Hi Richard,

    I recently installed Mercury SRS on my Ultra-flush jet and I think I'm running on version .5. I went through the whole set up and when I get to page 23 of the manual test flight assistance, I can’t seem to find that option on the main menu and if I find it on the 2nd page of the menu, it asks me if I want to erase all previous settings which I’ve already done twice. Below are the following issues that I have.

    1. I want to test on the ground the gyro functionality

    2. Do I need to upgrade the software to a later version and how?

    Thanks