Mercury SRS crash after update?

  • Hi,


    So disappointed...

    I powered my Mercury for the first time.

    Everything worked fine using the OLED screen.

    As I purchased the Bluecom Adaptor, I activated the PC Control.


    All still OK, the App first asked me to update (V11?).

    What I did.

    But after the update, problems started. I was first unable to select Sbus. When I scrolled to Sbus, it came back by itself to the first (Jeti ?).

    Thereafter, despite the Bluetooth recognises well the Bluecom, I’m unable to select the Mercury amongst all the other pictures of terminals available in the App. I push on the Mercury picture, but nothing happens.


    Then, I decided to revert to basic, unplugging the Bluecom, but the OLED screen is blank !

    I tried several times, depowering everything, the OLED shows always blank 😖


    I read on this forum that the update crashed the Mercury?


    Please help...


    Marc Stubbe

  • Hello Rudi,

    Thanks for fast reply.


    I managed (by a long push on the Mercury picture) to make a rescue of the box.

    Fortunately, that worked fine, I recovered the OLED screen !

    So far, so good... I guess everything will be fine, I’ll check that soon.


    Just the Bluecom doesn’t work.

    Bluetooth link is recognised, I see the Mercury picture (amongst the other boxes) on the screen but nothing happens when I push on it (except long push that gives me the rescue mode).


    I’m using IOS 14.4.1 on a rather old IPhone 5SE...


    Good evening,


    Marc