Competition SRS with 7003SB - failsafe delay

  • I have a Competition SRS with the latest firmware which I just updated ahead of installation into a new model, with 2 x Futaba 7003SB using port 1 on each , into RX1 and RX4 on the Competition.


    I have configured failsafe positions for throttle, Powerbox Sparkswitch Pro channels (in PWM mode) and clicked "teach failsafe" on the SRS.


    When i power off my TX:

    - RX1 counts up fades

    - RX4 displays "-"

    - Lost Frames displays "-"

    - Holds displays "-"


    This happens for 10-30seconds (appear to be random) after powering off TX, then Lost Frames starts counting up and the failsafe mode engages.


    Is this because the 7003SB in RX4 is not reporting a problem and continues to send frames even though it is not receiving anything? I feel there is a setting on the 7003SB which needs changing here?


    Thanks

  • They are both brand new and port 1 is in S.BUS mode. To test signal, I have already disconnected each RX in turn and they provide signal on their own.


    Also, if RX4 wasn't providing signal, why does PB Comp SRS delay in going to failsafe?!

  • I have also swapped RX1 <-> RX4 and the problem stays the same and does not move RX ports.


    I made a video :)

    Video of problem

    First you hear me power off TX and it counts up RX1 fades only and failsafe never happens (listen for throttle servo not moving), then when TX is powered on, you hear throttle servo move to idle, then i power off TX again and this time, after some time, the failsafe activates when you hear throttle servo move and lost frames starts to count up too.

  • I know, that's why I came here ;)


    The wires are both brand new from the shop from an official UK retailer (I lost the ones the SRS came with as it was previously used on DSM2). If I swap RX1<->RX4 the problem stays on RX1 port so the wires dont look like the problem. Failsafe is set in the Powerbox, I have no setup any failsafe on the TX/RX at all.

  • I've been trying to do some other tests to assess the situation. I tried my new 7003SB in my old PB Comp SRS v18 and they work fine, move them to v29 and they go wrong again. Put TX in Single RX mode and everything works correctly, put it back in Dual RX mode and rebind, problem comes back. I also tried 2 brand new wires from packet and tried 5.9v and 7.4v mode, no change.


    It seems this is a new issue either with my SRS or in the firmware since v18.

  • Is it possible that port RX4 is not reading the SBUS "failsafe flag"? Feels like this would be a firmware issue rather than an issue with my specific unit, is this something you can test without me sending my unit back?