Green LED on Micro Switch does not work

  • Good afternoon,

    I relocated the micro switch on my airplane and now the green LED light isn’t working. I just tried it again and that’s where I noticed and can confirm that the switch works but the green light does not. So in essence I have no indication if the switch is on or off.

    Is it possible to get a new switch?

  • MichelVR

    Changed the title of the thread from “Switch does not work” to “Green LED on Micro Switch does not work”.
  • Am I correct to say that the green LED is not integrated into the micro switch function of turning it on?

    I’m wondering if it’s possibly something else is causing this problem or did the LED fail? The micro switch seems to work fine and my Core telemetry widgets see the Pioneer and related PowerPak batteries. I can get everything to work, I just don’t have a green LED. Any help would be welcomed.

  • Hello Richard,

    Thank you for your prompt reply. I tried again and the LED does not go on and I also checked the connector and the pins are straight and everything looks in order. Please see attached pictures.

  • It’s funny as I just finished making all my servo leads for the plane and I had everything ready to go so I turned it on to do some more programming and that is when I noticed the LED not working. Maybe I wasn’t meant to fly this plane this week? 🤣

  • Yes I know the LED has nothing to do with BlueCom or update I just wanted to show you that the switch still works without the LED.

    Richard I just sent you a conversation with my address details.

    Thanks again for your excellent support and I will throw this switch into the garbage and wait for the new one to come! All the best and my regards!