Spark Switch Pro - Not recognized by CORE or Bluecomm

  • Hello to all,

    I bought my first sparkswitch pro for my new build, tested it on the bench, connected it to the bluecomm checked for updates. It worked perfect the first time.

    Later I built it into the Model with a Core / 26D setup as mentioned in the manual (connected the Tele to P2Bus). On powering up and searching for sensors, the switch did not show up. Tried a typical End to End troubleshoot (battery to cables etc…), I could not find any troubles.

    Then I pulled the switch out and tried to check it via a connection to the Bluecomm adaptor. The app does not connect to the sparkswitch anymore.

    Has anyone faced a similar issue ? Anything that I am doing wrong ? Any troubleshooting suggestions ?

    Thank you….

  • Hello Richard,

    Thank you for the quick reply...

    i am unable to see the sensor on the CORE.

    I am using a Pioneer and a 26D Rx. I have used a Y cable to the P2BUS in the RX to connect the Pioneer RX and Tele port in the Spark switch pro.
    When I power up the system, the sparkswitch pro is not recognised by the CORE.

    Will try to give it a fresh reconnection from cratch, trying to eliminate any errors...

    I am not sure where the problem is ! :|

  • If SS Pro was configured successfully in the past, and afterward was not updated or changed configuration, then does not matter what type of adapter you will use, BlueCom or USB adapter. There is some problem is hardware setup, cables or something similar. Try please removing all from SS Pro and again connecting only to App.

  • Hello again,


    I connected the Spark Switch Pro via the USB, it said that the Firmware was "Corrupt". I guess it could have occurred the first time I connected the Bluecomm and had a look at the settings.

    All is well now...

    Cranked the engine on for the first time today... Absolutely amazed by the "TELEMETRY" on hand.

    Thank you both for taking your time to help me out !

    Cheers !!