Rudder creep on bench setup

  • Hi guys, I hope you can help me. I am setting up a new Powerbox Mercury (Spektrum DX18, Hitec 8335Sh servos).

    I have gyro experience from previous heli days and a 3e in another of my jets. I found the setup to be very straight forward, I followed the manual closely and used the setup assistant and performed a simulated test fly assistant (set gain to 20%). Everything works perfectly except one thing, when I switch to Att. Assist All. the rudder servo starts to buzz and creep (model left). No other channels do this, only the rudder and when I switch FM to gyro off or Att Assist Ail then the rudder creep stops and the rudder snaps immediately back to neutral position. I have full control over the rudder at all times, the creep only happens when I release the rudder stick.

    I tested all other surfaces thoroughly and they work as expected in all flight modes, just the rudder behaves strange. It basically creeps or drifts left every time you activate assist all. Here are some troubleshooting steps I tried to see if I can alleviate the problem or cause a change of behavior:

    - charged rx pack
    - confirmed mercury set to hv
    - tried rudder in port rudder B
    - tried disabling port rudder B
    - confirmed no tx mix or trim in use
    - reset mecury and updated firmware (last Thursday)
    - turned model on its side while rudder creeping, same issue persists so not affected by model orientation
    - tried with gps connected and disconnected same result
    - tried with tm1000 connected and disconnected same result
    - tried servo frame rate at 12, 15, 18 ms all same result
    - checked linkages, cables etc all good
    - ran a range test all good
    - reset model angle, same result
    - this is all without turbine running

    - went in to gyro setup and disabled asst all on rudder in that flight mode, as expected the rudder creep/drift stopped immediately.

    Is it possible that the model has to be flying for asst all to work properly on rudder? I also tried resetting gyro gain between 50% and 20% and found that the creep happened much faster at 50% so its definately gain related. I did not try a different servo because the problem only happens in 1 flight mode it seems very unlikely to be a faulty servo. By the way does anyone know what frame rate hitec 8335sh servos should be configured for?

    thanks for taking the time to read this and looking forward to any suggestions.


  • Quote from "Richard Deutsch"

    This looks like a bad sensor. Please send us the unit for a check. Sorry for the circumstances

    Thanks Richard, this is a brand new unit and it's only my first time setting it up so I think I will do a full system reset and go through the setup process from zero again just to make sure I didn't screw something up. If the problem is still the same then I test it outside of the model, and if the problem still remains I will box it up and post it to you for diagnosis.

    Just one question, I know you have to "stir the sticks" at startup, should that be immediately after power up or do you have to let the gyro zero first? when powering on my 3e jet I am afraid to move the model in case it throws out the gyro, but then I'm also worried that I missed the initialisation window for the end points. Is there any way to tell when that end point intialisation window ends?


  • Also, would you happen to know what frame rate hitec 8335sh servos should be configured for? I tried looking at Hitecs product page but I can't find any reference of an optimum frame rate.

  • Hi guys, just an update - I reset my Mercury, rebuilt the mounting bracket at precisely 90degrees, and got rid of any carbon near the Mercury and the problem still persisted. I needed another Mercury for a different project so I bought another new one, changed it over in to my Rebel and now the rudder is perfect with no creep.

    Looks like Richard was 100% right I was unlucky and got a unit with a faulty sensor. I'll box it up on Monday and post it in for rectification.