setting the gain channel

  • Hi,

    When I try to manually set a channel for gain channel under input mapping, it appears the flight mode channel resets to -, when I go back and reset the flight mode channel the gain channel resets back to -.

    I suppose this behavior may be due to the gain channel auto disable feature? I see this in the manual under Gain Channel.

    "Once the set-up flight is complete, this function is disabled automatically."

    Can this be disabled? I'd like to keep a flight mode channel and a gain channel assigned, Let me know.



  • Hello,

    you can give you the answer yourself: With what gain should the gyro work if both can be assigned: the gain from the knob or the gain from the Flightmode Switch?

    Use the setup assistant, don´t make the things too complicate!

  • The flight mode switch sets the mode, FM1, FM2 or FM3, but the gain channel allows me to set the actual gain value during test flight assistant. that is what I'm trying to do, I'd like to run the flight assistant but it won't allow me to set a gain channel unless I rerun the setup assistant.

  • Are you saying this is done in the setup assistant? The plane is already setup, I'd prefer not to rerun the setup assistant, I do plan to use the test fly assistant but need to assign a gain channel.


  • Richard,

    I have a problem, I had initially setup the Mercury manually without the setup assistant, I have been programming my other Royals and iGyro SRSs without much issue doing it this way. I specifically do not like using the setup assistant as it sets the output mapping slots automatically, based on aircraft type. I prefer certain slots for certain functions to keep things organized.

    Due to the gain channel not being configurable unless you run the setup assistant, I hesitantly ran the setup assistant. When I ran it something happened to the pump, I had to unplug it as it just keeps running now, I'm using the same exact radio program which was working fine before I ran the setup assistant. After I ran the setup assistant I went in and modified all of the output mappings to match what I had already pre-wired and was working perfectly. I tried plugging the pump directly to another receiver and it simply just keeps running, no melody on power on. Did running the setup assistant with the pump plugged in damage it? How is this possible? Is there a way for me to reset it?

    Also, after I unplugged the pump I tried testing the flight assistant. Does the flight assistant only allow you to set all three axis at once? The Royal allows you to setup the gain for each axis individually with the flight assistant, was this functionality removed/left out? I have found on my other planes that the gain on each axis when I land after running the flight assistant is always different for each axis before it oscillates. Please help me with the pump issue and clarity on the flight assistant. Sending the pump to Germany is going to be a big hassle, I am hoping this is not the only option.

  • Hello,

    no idea what happened with the pump. Does it start to run only with power connected? Then the MOSFET is shot. But the remapping is 100% not the reason.

    Yes- the Mercury has only one dial to setup all three axis together. Most pilots didn´t use the assistant in the Royal as they fear the testfly and adjusting 3 axis. So we made it easier. You also didn´t use the assistant, so I see this is the right way.
    Even when the gain values have the same percentage, inside they are different for ailerons and elevator and rudder, so it will fit for 95% of all models. You can modify it after flight manually.

  • Hello Richard,

    could you confirm that the sentence "Once the set-up flight is complete, this function is disabled automatically." allows me to use the gain channel for anything else, as soon as the initial inflight setup has been completed and correct gain found for the mercury in each phase (FM1/FM2)?

    For exemple for a pyro mechanism or for any other element that would request a specific channel with specific ATV.

    I used the flight assistant in my Avanti with vector thrust at the very beginning for the initial setup, and now I would need one more channel for my model.

    Thank you


  • Hello Richard,

    During gyro setup following “Setup assistance” I have chosen for FM: 1- gyro off, 2- att assist std, 3- att assist all, but didn’t do ‘Test fly assistance” yet. Now I would like to disable att assist for rudder in flight mode 3. Should I pass “Setup assistance” again (Dont’t wont to lose all my rest Mercury settings) or after “Test fly” simply disable att assist for axis rudder-a and rudder-b?

    Thank you.