No Telemetry Data on 18MZ with R7003SB Receivers

  • Hi.
    I've been through all the topics and tried all the suggestions but still no telemetry data from the Mercury. All I get is receiver voltage. I have 2 R7003SB receivers.
    Even that is intermittent, mostly off. The signal strength meter on the Telemetry display goes off, sometimes three bars, mostly off.

    What is wrong?

  • Yes I know its the Mercury. The telemetry signal back to the 18mz is erratic. And only receiver voltage shows sometimes, all other powerbox signals not coming back.

    I have a complete identical Mercury system with R7003SB receivers and it works fine.

  • Neither method makes any change. In fact the reload erases all the telemetry display blocks except receiver battery voltage.
    I go to data reset and do that, then more boxes appear. Then I go to Sensor and add powerbox in slot 8 ID 3 as I read in another post and all the powerbox display boxes appear but still no data.

  • Hello,

    so your teleconverter is o.k. I know it´s frustrating, but playing arround with registering, new read and so on will lead to a working system. You can also set the Slots from 8 to 16- maybe this leads to data.
    It´s not our fault... it´s the registering process, I´m sorry.

  • I am having a very similar problem with my new mercury with GPS and the Teleconverter.
    My configuration is a Mercury, Teleconverter, GPSII, Futaba 18MZ, two R7003sb receivers.

    All Powerbox hardware is at the latest firmware level.

    I have it registered and I get pack voltages, gps data but no coordinates.
    Also I do not get capacity readings.

    I have used the Royal srs with Igyro and a teleconverter and it provided all data perfectly.

    I was up til 2am last night/this morning trying all the listed methods to clear/reset telemetry data, reload versus register, changing slots from 16 to 8 with the identifier of 3, etc etc

    Nothing I try will get me pack capacity data to my 18MZ

    I even tried creating a new model in the radio, registering the Teleconverter and then trying to get pack Mah data and I receive no telemetric data on mAh.

    Again, with the Royal srs, setup was quick and simple and I received all telemetry data.

    So with all that, I am thinking that either the Teleconverter is not functioning properly, or that the Mercury software is not quite ready.
    The Royal, being a more mature system works perfect as its had more time for bug reports and updates.

    Oh and I also tried updating my 18MZ with the latest firmware from Futaba.
    No change to my telemetry readings.

    Oh and one more question
    Ver 5 for the Mercury.

    What did the Igyro bug fix address/fix?

  • Quote from "Richard Deutsch"


    the Mercury has no Capacitiy data available!

    The Coordinates missing is a Futaba bug- they told me to fix it with the next update.

    Well that explains it then

    thank you.
    I really didn't know the mercury couldn't provide all the telemetry data that the royal can.
    Most figure the mercury is just a smaller version of the royal with two less regulators.

    From a consumer standpoint, what is the point of the mercury then?
    A newer six-axis MEMS sensor, smaller footprint, a screen only the best eyes can see and less regulation capability.
    The royal is still the King of the hill I would surmise.

    From the PB Mercury product description


    "Direct transmission of the battery informations, receiver data and GPS data to the transmitter"

    To me that means battery information including mAh
    Also GPS data includes coordinates, but no coords are received.

    Going back and reading the Mercury and Royal descriptions..I see the distinction.

    The Royal says it outputs ALL battery information
    The Mercury just says transmits battery information.

    I see what you did there

  • Quote from "Richard Deutsch"

    The Mercury can show coordinates, but Futaba transmitters have a bug. The only data you don´t get is capacity. This is because there is no more space for the measure parts on the PCB- it´s not to save money!

    I understand, thanks for the clarification on the capacity

    is it a Futaba bug pertaining to the Mercury?
    My 18MZ received coordinate data from a Royal SRS.