VT gains

  • I used the test fly assist on the ground as a test.

    VT -------

    Airspeed factor is 4..

    Gain is rate at 100%

    Flight mode 3

    Control surface--------

    Airspeed factor is 3

    Gain is rate at 68%

    Flight mode 3

    I thought the test fly assist was to change airspeed factor to 5 on VT and Control surfaces ( sure I read somewhere)

    Also change gain too 100% rate on control surface.

    Or do I have to make these changes myself??

  • Hello Aaron,

    only the outputs for vector control are set to 100%. Thats correct, like shown in your first post.

    Hi guys,

    Is it OK to use 100% gain on VT when slowly flying around also or only when trying to hover? that gain seems very high!

    Just doing my first VT setup now..

  • No Attitude assist on Je 3D!!

    Hi Richard, just to confirm are you saying DON'Tt use Alt assist All on the VT channels?

    I tried my jet on the weekend and it seemed to 'fall sideways' out of a hover even though I have the gains set to 100% and Airspeed factor 4. I did not have Alt assist All enabled so I wondered if that might be why.

  • Hello,

    yes- no Attitude Assist for Jets.

    This is because of missing airflow in Jets - the gyro is controlling the surfaces but the plane doesn´t do so. Once you give full throttle and the plane gets airflow you will have unwanted reactions.

    Vector thrust in a jet is not like in a 3D plane: the gyro cannot hold it itself in hovering position- you will have to control it. The gyro gives just a big support.

  • OK thanks Richard.

    I was checking my system tonight and found that the Mercury was reading GPS OK-lost-OK-lost-OK-Lost over and over again (yes i was outside). I tried another GPSII and it gave solid OK so i think my gps sensor is defective. That would explain the lack of gyro gain in the hover.

    Can I send in this GPSII for repair/replace?

  • Hi Richard, I'm from Ireland. I have 2 x GPS II devices both purchased last year. One from Als hobbies at Jetpower Messe and one from Nexus models UK webshop.

  • Here's a video I recorded outside in my back yard last night.

    Note also that while it looks like the GPS is mounted to carbon fibre it's actually ABS plastic with carbon look print

  • Hi Richard, just an update from my side on the issue. You are sending me another GPS2, but I wanted to fly my jet yesterday so I purchased a brand new GPS2 so I did not miss the weekend flying. Problem is that the new GPS2 did not fix the problem. Still from the Mercury GPS reading I have OK - Lost, OK - Lost etc.

    On top of this, during the week I had also updated the Mercury in my other jet to V05 firmware to take advantage of other fixes and enhancements. But with a sinking feeling I checked this jet at the site also and it to has OK - Lost, OK -Lost, OK - Lost :(

    So I have two jets with two separate Mercury+gps2 with the same problem now and they are grounded until we can find a fix. BUT - we did find one interesting thing, if you turn the DX18 off so it is not connected to the Mercury then the GPS readout immediately sets to OK and stays solid. Turn the DX18 back on and its back to OK -Lost, OK - Lost.

    Myself and my friend conducted a lengthy round of troubleshooting to see if we could narrow down the culprit for this issue, here are the things we tried:

    * Tested outside, at my house and the flying site - same issue

    * Moved jet around flying site to rule out RF interference - same issue

    * Disconnected Spektrum TM1000 unit - same issue

    * Rebound Mercury - same issue

    * Set up a new model memory and rebound that to Mercury - same issue

    * Took different DX18 with a different firmware and bound that to Mercury - same issue

    * Disconnected each port on the Mercury one by one to see if its was somekind of feedback - no change to problem

    * Tried a different cable to the GPS2 - same issue

    * Changed batteries in model - trying fully charged and low charged - same issue

    * Checked config of Mercury and firmware versions - both showing same level V05

    * Checked config of GPS2 and firmware versions - both showing same level V10 and set to igyro/ mercury SRS / Royal SRS

    * Tried changing the setting in the GPS to M-Link and every other type of telemetry option to see if any of them would stay on OK - did not work

    So, my conclusion is that from this testing we have eliminated:

    * Transmitter hardware

    * Transmitter software

    * Model programming

    * GPS2 hardware

    * Mercury hardware

    * External factors like battery voltages

    The only remaining culprit can be a software bug in the Mercury or GPS2?? Hopefully this issue should be very easy for you to replicate, you only need:

    1. DX18

    2. Mercury with V05

    3. GPS2 with V10

    If you get ok-lost, ok-lost, then turn off the dx18 and you should get solid ok.

    I have the same problem on two jets now - it can not be a co-incidence. Please let me know is there a way to roll back my Mercury to V03 because I did not have the problem before upgrading to V05.

    If you want we can do a Facetime video chat so you can see the problem from my side so you can see clearly my configuration and the fault.

    Thanks in advance for any help you can provide!