odd behavior on the Royal SRS

  • Hello,

    This past weekend I experienced a situation where I turned-on my radio (18mz) and then the plane, Royal SRS. The issue is that none of the servos would respond to commands from the radio, the screen on the SRS looked fine. I turned the plane off and on and the servos all worked fine. I ultimately flew the plane w/out issue.

    Today, I was preparing to fly the first flight of the day and my battery alerts (telemetry) began to go off. For example, it would read the correct volts on the screen of the Royal but on the telemetry screen on the radio it would go to zero for both volts and capacity for a second then revert to match the Royal's screen, and my alerts would trigger. It kept doing this until I unplugged the batteries from the Royal. I first tried to turn the plane off and on, I then tried to turn the plane and radio off and the condition remained. Once I unplugged the batteries from the Royal & reconnected, all worked fine.

    Lastly, I noticed one final odd condition recently. Not today or this week, but sometimes when I plug in a fresh battery the Royal it will automatically power on, it does not always do it though. I had planned on mentioning it before but I had forgotten until I was writing this post.

    I hope you can provide some insight on what is going on.



  • Hello,

    for the first: do you really have 16.9? In older version if Gyro sensor initialisation failed, the unit doesn´t start. 16.9 will should show a failure screen

    If the Royal screen shows voltage o.k. - something was bad with the teleconverter transmission or telemetry radion link.

    With automatic powering up: If the unit was one when you unplugged the batteries- it will come up with on condition once the batteries are connected again. Can you confirm?

  • Hi Richard,

    I'm positive the unit is running version 16, but I am now not 100% sure it's a .9 unit, now that you question it. I will confirm and let you know when I get back. In the interim, are you saying that when it exhibits this condition, it's actually an indication of the gyro failing to initialize? If so, why would it fail to do so? What are some causes or conditions which would trigger this? I'd like to ensure it isn't something I'm doing, or if there is a fix, I'd like to consider applying it.

    Regarding the second issue, The Royal's screen definitely showed the correct voltage and capacity. Are you suspecting a bad signal or faulty teleconverter? I did look at the telemetry signal strength link between the rx and (looks like a cell phone signal indicator) the 18MZ. It showed high bars, plus the rx voltage which is provided natively by the R7003SB never changed or fluctuated. Only the volts and capacity for batt1 and batt2.

    Last issue, I can say with almost 100% certainty that I do not unplug my batteries while the unit is still powered-on, in fact, I would cringe if I saw someone do that. Is it possible there is something buggy related to the automatic power-on process?

    As always, thank you for your great support and help. I will get back to you with confirmation of 16.9 as soon as possible. If you could help me shed more light in the interim, I would greatly appreciate it.