Steering servo twitches when turned off with gear sequencer

  • When I disable the steering servo with gear up it twitches in a constant pattern (every +/- 3 second). When it is enabled and controllable it is perfectly still. Looks like the off pulse generated by the mercury is not stable?


    Another issue is that sometimes the sequencer starts over in the middle.


    Looks like an issue with the sequencer somewhere?


    I am using 2 SBUS receivers with 9msec famerate. Everything else seems to be working fine.

  • I will try with one receiver only. I never had any other issues using 2 receivers at 9ms and in a cockpit everything works just fine. All channels are stable also, just the sequencer is a bit jumpy. Sometimes the sequencer even starts on its own :)


    But i discovered the steering servo jumps between the hold position and the actual channel position. When i don't steer the servo is in rest. When i steer to the left there are very small jumps to the left. When i steer to the right, small jumps to the right. So the hold output signal jumps between the hold position and the channel position.


    EDIT: Just tested with only one receiver on RX1, same issue.

  • Yes- maybe. You can map the direct channel to this output for testing.


    I must say a S.BUS signal with 9ms framerate is not a S.BUS signal. Original it has 14ms!

    Is it FRSKY? They should change it or remove the S.BUS compatible sign...

  • Yes it is FrSky. Is sends the SBUS packet every 9msec. As far as i know Futaba outputs SBUS every 7msec. I only know the 14msec from the PPM update when using the analoge setting, 7msec for digital.

  • So receivers with 7msec are not compatible also?


    But that does not explain why the steering servo output twitches between the hold value and the channel value. Should always be the hold value right?

  • Hello,


    with 7ms setting in Futaba receivers we cannot guarantee correct function.

    I assume that the twitching comes because some frames are receiverd o.k., some not. In the bad phase the servo goes to it´s hold value