• Richard,

    I got tired tying to get the telemetry to work. I will try again this weekend. I will go over your instructions again not to miss any step, I wish you can make a short video for all of us w Futaba radios instead of the going back and forth here.


  • I know it’s late message but just Incase anyone needs this info. I had same setup and gps was not working. I got the gps working by simply connecting the gps via bluecom and mobile terminal to update after updating I connected to gps via bluecomm then Selecting s-bus or futaba I am not sure. After that the telemetry worked. Just in case I am wrong u need to basically connect to gps and setup the correct options in the mobile terminal. That should work

    Good luck.

  • Wonder if Jellybean ever got this all figured out. Having these exact problems myself now with same systems. I’ve tried data reset and then reload, register, reset again, updated all software on teleconverter, Mercury, GPS2, and my Futaba 18MZ. Even tried a spare teleconverter but no luck. I set a Mercury up before with no problems, not sure what I might be doing different.

    There is no telemetry setup in the Mercury itself is there to enable telemetry? Just register the telecovnerter and then plug it in? I can't find such a menu option if it does exist anyway.

    One thing I’ve seen mentioned is reassigning the Powerbox to different slots in the Futaba telemetry sensor list. Not sure how to do that but should be able to figure it out.

    I also didn’t remember having to register the GPS as its own sensor last time either, since when I register the teleconverter it includes the GPS driven sensor items (distance, speed, altitude etc). Regardless I’m not even getting voltage so I know he basic functionality is still not there. I am getting voltage readout from my receiver, just not from the Powerbox.

  • Well now I’ve done it. While typing all of that up I got myself motivated to go out into the cold garage to figure out how to reassign slots, which was easy enough, and upon moving the Powerbox from starting at slot 8 to starting at slot 16, everything works. Including GPS parameters without registering the GPS2 separate from the teleconverter. So it’s seems I’m all set.

    Can anyone clarify, I believe the only reading I won’t get from Mercury that I get from the Royal is mAh used, is that right?

  • Hi Richard,

    today I'm really so confused :-)

    Yesterday was all functional: Mercury + GPSII + Teleconverter + 2xFutaba receiver + SparkSwitch Pro, means all was connected, all worked properly, only GPSII was configured to M-Link, Teleconverter was configured for All Futaba transmitters.

    Today arrived USB Adapter, I connected first Teleconvereter, changed configuration to SZ18, saved, connected GPSII changed configuration to first option iGyro/Mercury/Royal instead of initial setting of M-Link.

    Again all connected together, but GPSII is invisible - Searching...., telemetry is empty. I again tried register teleconverter sensor, but now transmitter is rejecting registering of sensor, reporting connected sensor is not ready.

    I rollbacked all changes to initial values, means M-Link, All Futaba transmitters. The same, nothing is working.

    could you please explain me what happens? When I again connected USB to both devices, all was visible, configurable, working fine, but connected to mercury is failed.

    thanks in advance, looking forward for your post



    All reset again and set up again. Now is GPSII and Teleconverter working properly, GPSII was set to iGyro/Mercury/Royal, Tele was set to 18SZ. Its alright.

    Sparkswitch Pro I'm unable set up. Tried P2Bus + bus channel 12, connected to tele input on mercury, not able switch 0/100 using appropriate channel 12. Tried S.Bus setup, connected to S.Bus together with Tele, passed to Mercury over passive S.Bus hub (or Y, does not matter), not able switch on/off using ch 12, not working.

    I'm really disappointed, following exactly instructions posted in forum/manual, and it's working like windows os, never doing what I want :-(


    well, SparkSwitch Pro is working, connected to S.BUS in receiver together with teleconverter.

    Reason why not worked? Funny, LED connected to Switch had swapped polarity - Red -/Black + (some output quality check???)

    How we can enable telemetry? If Teleconverter is registered as sensor, SparkSwitch data output + Teleconverter S.BUS output are connected to S.BUS receiver port, in that case your post Futaba + SparkSwitch is not accurate, we need to receive both telemetry, Mercury + SparkSwitch - is it possible?

    Can you please xplain what we need to enable both telemetry?

    thanks in advance, because right now I tried:

    1. Following your instructions in your closed post Futaba + SparkSwitch - in that case is possible to use ONLY SparkSwitch telemetry, registered teleconverter disappear and not able to see voltage/gps etc etc

    2. Used P2Bus as tele input - not working, used s.bus + reload telemetry - not working, used separate setup for both - its working always only for one telemetry


    All is set :-)

    I will post detailed setup of whole possible configuration of all above with pictures. Maybe it will be useful for all newbies as me, saving lot of time with investigating.

    It is working all very nice and properly!!! Great product (excepting missing of some documentation)

    Also RPM is measured properly and accurate from OS MAX ignition (using my approach described in SparkSwitch thread)

  • Hi ! Hope Richard or Rudolf can tell how to make this works.

    I have read and followed everything.

    on T18SZ --> upgraded to latest version FW + Data reset + reload teleconverter. Played with position 8 or 16 too.

    checked Telemetry that is active for rx

    on teleconverter --> upgraded to latest FW version

    on RX1 (R7003SB) --> plugged the teleconverter (sbus2 side) to SBUS2

    on Mercury SRS --> plugged the teleconverter (powerbox side) to "TELE" port (light yellow wire facing up)


    when I disconnect my SparkswitchPRo from my RX2 (R7003SB) SBUS2 port and I plugged my teleconverter I get GPS data but I don't have a GPS. like 780km/h, 780m, etc..

    This is the only thing I got so far.

    what else can I try ?



  • Hello,

    you see the GPS data because Futaba made a "Powerbox Sensor" which contains this data - ou cannot remove it.

    You have to connect both to RX1 - Futabas vintage telemetry system cannot send telemetry back from both receivers. Only one receiver has telemetry.

    So you connect the Mercury Teleconverter and SparkSwitch with a Y-harness to RX1. Set the SparkSwitch as shown here: Einstellen des SparkSwitch PRO auf Futaba