Shacking effects on control surface

  • Hello,

    I’ve just received my new Mercury box for my 31Kg F15 jet and I appreciate all the great functionalities of this compact device.
    However, I have a big issue with all servos as there is an unacceptable shaking during servo travel. No problem at centre position, only when stick are moving, whatever slowly or quickly. This shaking is important on large control surface as the big elevator on large F15.
    Of course I have read other threads on this forum and I have done the following tests:
    Change output voltage 7,4 to 5,9v
    Test all the framerate from 12ms to 21ms (better to 21ms but still shaking)
    I am using 2 PAD (Power Absorbing Device) from HITEC as I use Brushless servo, I also tried 3 or 4 PAD without effect.
    The fact is when servos are plugged on the receiver GR32, there is no problem at all, no shaking effect, so it seems the issue come from the mercury.
    My configuration is the following:
    Mercury SRS V08
    2 Receivers Graupner GR-32 (HoTT output S SUMD of 16)
    2 LiIon batteries 7,2v 5200mAh
    All servos are Digital HV, high performances.
    Servos used are the following: Hitec Brushless HSB-9380TH and HSB-9370TH, Graupner Brushless HBS860BBMG and Coreless HCM870BBMG
    I also tried to reload the update (V08) via the Bluecom adapter, and the control what ok during the first minutes but the shacking effect comeback after 10 minutes.
    I will post a video to show the shacking effect on elevator.
    I assume that I cannot perform the maiden flight with this situation, and the French autorithies will never accept to deliver the flight acceptance for this model with such flight control shaking.
    Thank you for your support.

  • Hello,

    what I see here is not a shaking- it´s rough running - not smooth. This may come because of the different framerate of the systems. The receivers comes with 10ms framerate, the PowerBox internal wirks with another framerate and the servooutput is adjustable.

    I you hold the stick at any position- is it quite? Also if you run it very slow- is the resolution o.k.? And if you move the stick fast- does it follow your stick?

  • Hallo Richard,

    The framework is setting at 20ms on my RX but anyway I remember the framework output from the S port (SUMD) is 30ms.

    I have tested all the framework setting on the Mercury, from 12 to 21ms. 21 is better but still not good.

    Yes if I hold the stick, the position is quite and very clean, no problem. When I move slowly the stutter (not smooth moving) is small and yes this effet will increase when I move faster the stick. So yes the servo follow quite well the position of the stick, no issue. But the transition is really not clean and not acceptable.

    This morning I have update the RX firmware with no effect... But I have notice that the servo became very clean and smooth (normal!) if I disconnect one of the 2 RX, whatever the RX. So maybe the mercury has some issue to merge the 2 SUMD signal?

    Thank you for your support


  • After some tests, I got good results with only 1 RX connected (disconnected...) but after 5 or 10 minutes the stutter effect comeback...

    Just in case, I have tested with GR24 (SUMDof16) and same results... really a problem with the Graupner Digital Signal.

    Do other customers have the same problem? If not I will send you my Mercury box for checking...

  • Thank you for your feedback Bob. I guess most of the time this will not have effect during flight for calm and realistic demo... but what a pity install expansive high performance servo to finally set the lower framework and move it slowly...

    I hope Powerbox will upgrade the Mercury...

  • Hello Frank,

    That´s really strange why the problem comes after 10 minutes... the PowerBox does the same thing 100 times a second, why should there change something after 10 minutes.

    My information is that Graupner cannot set the framerate of the SUMD ?! If you can set the framerate here, this may eleminate the problem.

    One more test can be let it run for 10 minutes, once it´s bad remove one receiver and check if someting changes. Connect the receiver again and remove the other on. Both receivers had been reset then. If the problem is gone then- it comes from the receivers.

  • Hello Richard,

    Yes I have tried to disconnect receivers one by one, even with different models GR32 or GR24, in different combinations (2x GR32 or 2xGR24 or GR32+GR24) always the same result, servo travel is dirty.

    Now I have the problem right after power on the box, not afte 10min.

    I have tried a factory reset, it was ok during the first minutes but then the problem cameback again ?

    I have the problem on all servos, but it is more or less acceptable depending on the servo type. On ailerons it is acceptable, but rudder elevevator and flaps it is not!

    Thank you for your help.


  • Richard,

    I really would like to solve my problem with the mercury SRS. So I think the situation is simple, 2 solutions :

    1. Your Mercury SRS is not fully compatible with Graupner SUMDof16 ==> you have to update your device (or I have to change my plans...)
    2. Or my device has a trouble and I will send it back to you for repair under warranty

    Thank you for your reply


  • Hello,

    I think we cannot fix that in just some days- we are actually very busy and from my side it doesn´t look like a Mercury problem. It´s a framerate thing on the SUMD output. As I told you there is no problemm flying with that- the resolution is fine and the servo speed is given.

    Maybe you can try different throw settings in the transmitter and changing the linkage in order to have the same throw. This may help.