Not able to update

  • Hello,

    I am trying to up date my cockpit SRS via the USB adapter and my pc. The program recognizes the cockpit and says there is an update available. I click on update then the screen went blank on the cockpit srs and then the progress bar never went past 0%. I left it connected for 30min and the progress bar never went past 0%. I tried to abort the process but nothing was responding. I disconnected the power from the cockpit srs, and now it seems to be bricked. (Not responding). The leds on the switch work, and I can turn it on and off, however the screen never turns on, and the cockpit srs is unresponsive. Now when I try to reconnect the the USB is says no device detected, which I assume that’s because it’s not in PC mode. Unfortunately though the screen won’t turn on so I’m un able to do anything with the unit. Is there a way to force it to connect and retry the update?

  • Ok a little update, when I tried the update process again, it comes up in RescueMode. I select the cockpit srs v26 file, then click on update and it’s doing the same thing. Seems hung up on “Preparing...”.

  • Hello!

    I own an older version of Cockpit SRS (s/n: 098677). Can it be upgraded for Graupner Hott reciever Support?

    The reciever selection menu doesn't have one at the moment..

    Thank You!