Futaba 18mz + teleconverter

  • Richard

    I know you have been through this many times but I looked in many threads here on the website and couldn’t find a solution.

    18mz WC and Mercury SRS with teleconverter

    Works on slot 8 but not slot 16

    I need it on slot 16 because I have turbine telemetry on slot 1.

  • I got the slot changed to 16 and is working perfectly. But I have another issue now. When I connect the turbine telemetry through a Y to receiver number 1 to SBus 2 port powerbox stops sending data. How do I fix this?

    Is this a problem with the Futaba receiver ?

  • The ECU is a xicoy I am using a sensor made by Lior Zahavi and using the sensor slot JetCat V10. The sensor has assignment between 1-18 and I have set to 1 and the teleconverter set to 16

    Whenever I plug the turbine sensor into the Y lead the teleconverter stops transmitting data. I tried everything I am about to give up on it and just use one

  • Hello Aalfawaz,

    Richard is right a common use of Slot numbers is not allowed.

    A typical T18MZ customer installation with a data converter from us for example looks like this:

    Slot number 1---> FSS-xxx IAS Speed Sensor

    Slot number 2 up to 15---> FEPC data converter for JetCat Turbines, Kolibri or Projet ECU´s. (Not supporting XICOY ECU´s because of a missing solution for galvanic seperation)

    Slot number 16-31 ---> PowerBox Systems Teleconverter running with different PB products like Mercury etc.

    Are you using the so called "JetCat Display" in your T18MZ Slot number list? I´m wondering because the "JetCat" Display uses 15 Slot numbers and can not overlap with the PB Teleconverter. Except the sensor/dataconverter would broadcast on wrong slot numbers.



    CB Elektronics

  • Hi Dirk and Richard

    What I meant is that the jetcat sensor can be programmed to have any of the slots. So I assigned it to slot 1 in the sensor menu after programming it for slot 1.

    Then I programmed the teleconverter to slot 16 then assigned it to slot 16

    When I use each sensor independently into sbus2 port they both work fine.

    As soon as I use a Y to connect them together the teleconverter value freezes on the screen. I tested this by unplugged PB battery the values stay the same. I unplugged one receiver I don’t get any values for fades anymore. And so on

  • Hello Aalfawaz,

    your last picture is showing a sensor list with the JetCat display occuping/sitting al Slot numbers 13 to 18.

    This is strange and wrong.

    I would suggest to clear the hole list. You can manually delete all enties.

    Then assign mannualy the slot display to Slot number 1-14 and the teleconver to 16-31.



    CB Elektronics

  • Dirk thank you so much for trying to help. However I am a little confused in the last picture I have jet cat from 1-14 then teleconverter starting at 16.

    Or is there something I am not noticing ?

  • ...OK maybe this Picture was a bit misleading for me. I only saw Slot number 16 and 17 at the right side beside "JetCat".

    Maybe the Picture is not showing the teleconverter in the list. And These number belong to the teleconverter.

    If teleconverter starts with Slot number 16 it would be fine.

    Then it comes to the point that maybe the data converter is broacasting not on Slot 1-14.

    From your discription it could be very likley that the converter is occupying Slot numbers 16 or above from the teleconverter too.

    But that is difficult to say without not measuring the Sbus2 data stream.



  • Hi all.

    I've 18MZ, PB Royal, PB teleconverter, Futaba R7003SB rx (2 x) and Jetcat FADEC V12.

    I could register Jetcat Fadec as well as PB Royal and assigne them to 18MZ rx Slot 1 and Slot 16 respectively.

    No probs in having PB telemetry data (ingluding GPS, even if LAT and LON always indicate 00:00:00N and 00:00:00E, speed is fine).

    Instead, no data received from Jetcat V12 Fadec. Very few times, after having powered off/on the Fadec (includi8ng 2s LiPo), I receive something at very first tx power on, but data non coherent (or better, coherent but not of the current situation in terms of Rpm, Temps etc.) and above all freezed. Rest of times, no data received from V12 Fadec.

    I also tried to connect only the Jetcat V12 fadec to Futaba Sbus2 port, same result.

    Any hints or anyone using Jetcat V12 fadec with 18MZ + SBUS2 Futaba rx?

    Thank you!