DX-18 Binding

  • I am setting up a DX-18 version 1 with a new Mercury SRS and no matter what I try I cannot get the SRS to bind to my radio. I have (4) SPK 9745 remotes. No matter what combinations I use in the SRS or framerate settings the same result. The satellites blink in bind mode, but after what looks like a successful bind from the radio, the satellites don't have a steady light. They all go dark.

  • Here is an update on this problem. I put the satellites in another aircraft that I had and bound them and they worked fine. Put them back in the Mercury after they were bound to the other aircraft's receiver. Using the other model in my radio that I had bound them too and plugging them back in to the Mecury they work. Tried to rebind them to the Mercury in a new model in the radio and same problem occurs. It appears the only way to get them to work is to bind them to a different Spektrum receiver first.

  • I am using DSMx 18. I am able to bind to an existing model in the radio but not a "new" model I create in the radio. So the problem is in my radio not in the Mercury. Thank you for your response Richard.