RPM Pickup not working with DA 70?

  • Has anybody managed to get the RPM pickup sensor to work with a DA 70?

    There seems to be no output, rpm just stays at 0.


    I then tried the same RPM pickup sensor and sparkswitch pro on a DLE 30 and it worked fine, so assume the sensor is ok.


    Thanks.

  • On Sunday I tested the RPM Pickup device with DA 70 boxer. Can't post here the video (25MB after my compression :-( ), maybe Richard has some utility for compressing the video and can post here. It is working properly from my point of view. Of course, the RPM's jumping on tens/sometimes on hundreds, but RPM is readable. Better results we have with Valach/OS Max, the worst with MVVS.I want to post recommendations here, only not time, I hope that today evening will able to share pictures from an installation with you.

  • Thanks for the replies.


    Here's the current installation:



    I've tried it closer to the ignition box, closer to the spark plug, looser and tighter coil spacing and on both plug leads.

  • Is there any update on this RPM sensor with the DA 70?

    I have tried the setup in the other threads with the pickup wire extended and kept the wiring away from the ignition unit and other wires but still it does not pick up the rpm.

    Thanks.