Mercury SRS failed update

  • Hi,

    Yesterday I tried to update my Power Box Mercury SRS (SN: 235197) that I bought at the Jet Power event on 2016 and was never flown yet.

    The update process wasn’t good and not by my fault.

    I connected it to my Android phone with yours Bluecom adapter and as the application started it connected to the Mercury SRS and immediately wrote "preparing" current ver. 3 and ver.10 available.

    It didn't asked me if I want to update, I just waited that it will continue and after a minute the LCD of the Mercury went black and after a few more minutes the application on my phone went back to the main screen and since then the Mercury SRS has gone dead.

    It is very frustrating that this process was so wrong and not from my side.

    Should I sent it over or there is a way to reset it?

  • Hello sharon,

    may I ask you for some details, please? You connected Mercury to Mobile Android App and the update process was started without asking Yes/No?

    After a not successful update you connected again Mercury and choose Rescue mode and run it?

    I'm so curious because it should be always asking if you agree with the update.

    Many thanks for your response

    Have a nice evening


  • yes, exactly.

    I don't know what it did exactly at the back ground.

    After i choose the Mercury SRS it wrote "preparing", about a minute after that the screen went black and after a few minutes later it disconnected from the app.

  • many thanks for the feedback, really no clue how happened this case, because the 'update process' is thread controlled by user response :-(

    I'm unable to reproduce this case.

    Again, thanks a lot



  • I tried all cases, really it is technically not possible :-(

    Initially, App is informing that a new version exists, and asking for acknowledging, then second user action is needed, starting the update.

    After starting the update, the Mercury (or Royal, Champion, tried all three) display is black of course, then, when finished firmware upload is getting back to the initial screen.

    I'm confused.

    What phone or tablet you used please? I tried the operations on Android 7 till 9.

    Anyway, thanks for your feedback


  • Hi Rudolf,

    I had the exact same problem with my Mercury.

    I have never used the control unit before flying.

    I connected the Mercury to my Android phone Oppo One Plus, updated to the latest version as well as the PowerBox app.

    During the software update from versione 8 to version 10 the word "Preparing" appeared and then the display turned off. The update has stopped.

    When I restarted the Mercury the display was black.

    I used the "Rescue Mode" which forced the software to version 9.

    Then I updated from version 9 to version 10 and now it works.

    If you need more information, don't hesitate to contact me for more details.

    The forum is very useful.

    I hope to fly soon with my new Mercury!


  • Hi Andrea,

    one hour I tried to simulate this case and was successful :-)

    I choose to update, and manually break the connection to BlueCom, it means, that I removed the connector from the device and connected back immediately. On phone in that case you can see very short message reconnection successful, but when you click to update button, after reconnection, then appear preparing message and the upload is not successful. Then after rescue and upload without broken connection all is fine.

    It is really important information from you, I will implement the method, which after clicking to update button will again check the status of connection!

    many thanks for your input!

    have a great rest of the weekend