iOS Mobile Terminal BlueCom App

  • Hello,

    tonight was released version 3.12 for iOS and Android. It is the first release of both platforms, using our new application approach, where we are able porting both platforms from one App code :-)

    iOS 3.12 is still not visible in Apple Store (as usual), but during the morning will be!

    I know about some common errors on both platforms. Testing was successful, but after release, we have to align configurations and correct some errors in ported code. For instance, still, problem with localization, China traditional and simplified phone language, in some devices is not working automatic update, the wrong version is shown (SparkSwitch and iGyro 3xtra). Therefore preparing 3.13 for both platforms, it will be released tomorrow, to fix those errors.

    From now, both Apps will be released in the same version, together, without delays between platforms.

    Many thanks for all your feedback regarding bugs, and improvements, we got in the last couple of weeks!!! The goal is to have absolutely safe and user-friendly App for all!



    EDIT: Finally, the App 3.12 is available also for iOS :-)

    On the iOS side, you should install the update, Apple does not agree with automatic updates.

    On the Android side the update of App is automatic, after starting the App, if exists newest version, App is updating self.

  • Hallo Rudolph,

    habe heute ein GPS-2 per Mobil Terminal ein Update gemacht. Das hat aber erst beim 2. Versuch geklappt. Eigentlich immer stürzt die App beim ersten Mal bei der Auswahl des jeweiligen Types (z.B. GPS 2) ab. Beim 2. Start dann kommt die Verbindung zustande und die App läuft wie gewünscht.

    IOS 13.3, Iphone XS MAX, Terminal 3.15

  • Tried today to update a sparkswitch pro with bluecomm (iPhone x, app 3.15, iOS 13.3). Connection was ok, but when I tried to update, the terminal said that the switch was already on the latest version, but it was on version 02. Then tried with pc and usb and it updated with no problems.

  • Hello Rudi

    An update to my micro match problem of last week. I ordered a new micro match that came today. Hooked it up and everything worked great. The only problem I had was the green sliders move very slow on my Apple phone, but they do work after eventually getting them all the way over to the side of the bar for adjustment.

  • Hello Calltheball :-)

    honestly, it is intended behavior, I created maximal step and delay 500ms between steps. But, right now I tested Micromatch as well and it seems the step is really small. I will include in the new version updated Micromatch control as well. I will increase the step 2 times. What you think, will it be enough? And delay 250ms between steps.

    Let me know



  • Rudolf - Also ich konnte es nicht wirklich reproduzieren. Auch heute beim erstellen eines Uservideos zum Update des GPS-2 ist die App beim 1. Start abgestürzt. Danach ging es ohne Probleme. Musste ich aber neu anfangen mit Video, weil ist ja nicht grad zielführend. Da ich ja nichts anders gemacht habe beim 2.Mal. Was mir aber aufgefallen ist, das wenn man ggf. aus Versehen 2x einen Button anklickt, dann kann es auch zum Absturz kommen. Das mir auch paar Mal passiert. Vielleicht ein Ansatz dazu....

  • hallo,

    Flugass: Ich bereite einen Hotfix für Click-Button-Reaktionen vor. Ich werde es heute Abend veröffentlichen. Es wird eine längere Zeit für den Rettungsmodus geben - 3 Sekunden und das Ignorieren von Doppel- / Dreifachklicks. Wirklich, in iOS 13.X kann es dazu kommen, dass die aktuelle Ansicht neu geladen wird.

    danke für eure eingaben :-)



  • Hello All,

    because I got a lot of complaints from some users, that App is not working properly, because after clicking to the device image was invoked Rescue mode, I fixed that using really long time for the long-press - instead of 2 seconds now the time is 3 seconds. This fix is in new version 3.16, available on the App Store.

    It is the difference between a click and a long-press. Long-press means holding the finger on the device image or button if you want, and after some minimum time - in the past 2 seconds, now 3 seconds - is this operation treated as long-press and is invoking Rescue mode. In case of normal click to the device image or tap to the image, is normally invoked the device setup. On the initial screen, you can find the info icon. Clicking to the info icon you will get information about tap/click and long-press.

    Even, if somebody will hold the finger more than 3 seconds on the device image, and Rescue mode is invoked, then the user will get information, that the special Rescue mode was invoked, and in case, if the device is okay, then the user should click to NO.

    I hope, this avoid user confusion, and all will be okay :-)

    well, in the next 2 days I will release version 3.17. In that version I changed the Update process, it will be 10x faster, and versioning of devices with the bootloader 2 will be corrected.


    Regards/Gruss :-)


  • Hallo,

    ich habe gerade versucht, meine Mercury SRS mit den Bluecom Adapter über mein Iphone zu updaten. Es ist die V3.16 installiert. In der Mercury bin ich in PC Control, der Adapter steckt an Tele. Der Bluecom Adapter wird vom Telefon auch richtig erkannt. Wenn ich in der App auf die Mercury tippe, passiert nichts. Wenn ich länger drücke, erscheint der Rescue Mode. Was mache ich falsch?

    Gruß Heiko

  • Hello,

    first of all, check the position of BlueCom connector, signal up, ground down. Mercury in PC Control. Run App, choose Power Box Systems:

    on the Mercury display you can see Connect Data Link....

    then click on Mercury button:

    On phone you will see initial menu. On Mercury display you will see BlueCom control.

    Then choose one from the item in menu:

    And you are able to set-up the Mercury.

    Let me know if it is working



  • Hallo Rudi,

    ich habe alles genau so angeschlossen. Ich habe auch die App noch mal deinstalliert und neu geladen. Ich komme nur bis zur Auswahl der Powerbox Geräte. Wenn ich kurz auf das Bild der Mercury tippe, ändert sich nur ganz kurz die Farbe, aber es passiert nix. Die Mercury ist noch eine V2. Kann es vielleicht daran liegen?

    Gruß Heiko