Competition SRS update issue

  • Hi,


    I was updating my brand new Powerbox Competition SRS today and in the middle of updating the software from V25 to the latest V28 something happen during the update and my phone locked up. I reset everything but now the screen is not coming on on the Competition. What should I do?

    Thanks

    Shannon

  • hello,


    always interrupting the update process is dangerous! But for that cases, we have Rescue mode as mentioned Richard.

    Please follow the instructions below:

    1. Disconnect from the unit all cables, only the BlueCom adapter should be plugged in the Tele port connected. Be aware of the correct connection!

    2. Connect Competition SRS to power, if after the connected battery is automatically switching ON, then great, if not, then you have normally switch unit to ON using the switch. Unit MUST be switched ON, LED's should lighting!

    3. Start App, choose category PowerBox systems, be sure that App is connected with the BlueCom adapter, Bluetooth pictogram on the right bottom corner should be blue, not red!

    4. Based on the used App, if iOS, then long press to Competition SRS unit button, at least 3 seconds, if Android then go to Rescue mode in the main menu

    5. Start rescue. After device recognition, click to the Start button, then after a couple of seconds, max 30 seconds should be changed mode Preparing to Upload. Please wait until the rescue will be done, do not close the app, do not enable screensaver, the app must be active during the whole rescue process.


    If something happens during the steps above, and mode preparing is not changed, then repeat the procedure again!


    let me know if it works

    rudi

  • Thangs guys,


    Its working now. I first tried the rescue mode on my iPhone and it just kept saying “preparing”... could not get it to start rescue. Before giving up I tried with my iPad and it worked as it was supposed to and went into rescue mode. All good now!

    Thanks for the guidance...

  • hello Gotspg :-)


    I'm so happy that it is working, but a little bit sad that it was not working on the iPhone! It must work on iPhone as well without issues. Maybe there was some connection problem, I do not know but it must work. I'm pretty sure that the iOS version on your iPhone is the same as on iPad, no differences and in that case, it is absolutely the same case.

    Please let me know if the versions are the same and which versions.

    Generally, if Rescue is not starting properly, saying Preparing, App is not able to read identification response from the bootloader. In that case, I would recommend always switching the device off, wait for 10 seconds, switch on and repeat Rescue. From my point of view, you did that but changed the iPhone to the iPad, and it is the reason why Rescue started on the iPad.


    Many thanks

    cheers

    rudi