Teleconverter + mercury + Futaba 18mz

  • hello,

    I’m having tremendous fun trying to get telemetry data working on the above combination.

    I have successfully managed this on another model, but it’s not working on this new model.

    I have linked two receivers, and activated the telemetry on receiver one. I do get on the transmitter the receiver voltage and three transmit bars.

    I also have a xicoy telemetry sensor which mimics the jetcat V10 sensor. I have now disconnected that to avoid confusion.


    first question, when I connect my bluecom, it doesn’t give me the option to set this as the current or powerbox sensor.

    It only gives me two tabs, one for “all Futaba transmitters” which is green and a tab for T18, 18mz, t14sg.

    I’ve tried both tabs but it doesn’t help. I’m confused as to which tab I should select...would “all transmitters” not include the 18mz?


    I have followed the threads at the top for Futaba 18mz completing a telemetry data reset.

    I have also tried to “reload” with the teleconverter attached to the receiver (Sbus2 port) and curiously at one point displayed the CUR F1678 in slot 2


    I was a bit surprised by that!


    Before I go further, I should probably confirm the bluecom settings...

  • after 24 hrs of it not working, 30s after I posted above, I’ve had my first bit of success...


    I selected the right tab on the bluecom, for T18-to T14SG.

    I then reconnected it to the mercury.

    Pressed reload.

    Selected powerbox on slot 8 and I now have the battery voltage.

    I can not select it on slot 16 .which I need to allow the xicoy engine data....

    What’s the highest slot ISHOULD be able to put it on to?

  • Thank you.

    I now have another problem.

    The mercury uses 12 slots, and can be located on slot 8 or 16.


    The Xicoy telemetry mimicking the jetcat V10 uses 14 slots...and can be put on, according to the instruction, you guessed it 8 or 16.


    Therefore I cannot put either on 8 and the other on 16 without a conflict.


    I can’t be the first person to be in this situation.


    I also cannot get the transmitter to recognise the xicoy unit to even attempt to change its slot position. But it will provide telemetry data if on the transmitter I select slot 8