GR-12L Hott not detected in Mercury SRS

  • I have two Graupner GR-12L receivers in the receiver ports of the Mercury SRS. Neither is reflected in the status of the OLED screen. In the telemetry field of the mz-32 transmitter there is no option for a “SUMD of 16”. The only option for SUMD is in the CH6 selection field. The only option of “16” is found in the RSSI field. CH5 only has options for “Batt V”, SENSOR, and SERVO. There simply no options to reflect what is in the Mercury SRS manual. I have no output to my two test servos located in the Throttle and rudder Mercury outputs. I tried a GR-18L. The only option for “SUMD” is a “yes/no” choice for a SUMD at CH6. Again no choice or offering for “SUMD of 16” The transmitter “sees all receivers the Mercury does not. What have I done wrong based on the offering in the Mercury manual for Hott transmitter and receivers?

  • Hello,

    you must have a option in the receiver menu for SUMD-OF-16

    If you find SUMD it comes out at CH6. But I don´t know if the GR12 has the correct output - the GR18 must havbe it.


    If you don´t find it, Graupner service would be the correct address to ask.

  • Thank you Richard and Flugass, I will look at the receivers I currently have on hand to see what is available to locate the “SUMD of 16” option. Again, I looked in the telemetry options in the GR-18 but again the only reference to SUMD was the yes/no option of SUMD at CH 6. As Flugass seemed to be knowledgeable of the Graupner systems. He should be aware Graupner is in a state of confusion (bankruptcy I believe) making the receivers harder and harder to locate in the USA. I just inventoried my available spectrum satellites and found the minimum requirement of 4 DSM X types. I will try the Spectrum route until such a time I can secure the types Flugass referenced. Again Thank You both very much for the assistance - I love the RC hobby world, everybody always leaning forward to help out

  • Hello, I had the exact same problem.

    I connected two Graupner GR-12L SUMD receivers (Art. S1051) to my Mercury SRS (version 11).


    the Mercury display says:

    Rx1: OK

    Rx2: OK

    But no signal is received by the Mercury.


    After many hours of testing and testing, I partially solved the problem by downgrading the receiver firmware from version 2.06 to version 2.04.

    In the new firmware version there are 4 types of SUMD (Graupner OLD probably 16 channels, Graupner New probably 32 channels, Futaba SBUS, Spektrum SP2048).

    In the old version of the firmware there is only one SUMD and in the instructions it is specified that it is a SUMD-OF-16 (as required by Mercury).


    I have configured the Receiver as follows:

    Framerate: indifferent

    CH6: SUMD

    CH5: SENSOR (Telemetry)


    But now I have another problem: Mercury does not always detect the receivers at start up, sometimes I have to disconnect the batteries and reconnect them ... I will keep you updated on the evolution, if you have any suggestions they are welcome.


    Andrea