Failed update PB Competition SRS, no-go on retry

  • Hello,


    I have today updated a few of my Powerboxes with success, but one Comp SRS failed when reaching 45%. It stood dead still for 10 minutes and I disconnected and reconnected but still the Rescue program failed to start. I restarted the computer, Terminal program several times.

    The upgrade was from V2.7 to 2.8. Now there is no connection, the screen says only " No Powerbox-Device connected.


    Any good tips will be well received.

    Thank you.


    KennethRK

  • Hello,


    Today I had the same issue with my Competition SRS , the firmware update failed at 70% and now the screen stays black.

    The upgrade was from V24 to 28. Now there is no connection, the terminal screen says only " No Powerbox-Device connected.


    Regards,


    Alain

  • Hello Alain,


    I tried several times interrupt update of Competition SRS by disconnecting of the power supply. In that case the update is really totally broken.

    After that I switch off the competition, reposer the competition (screen black, can't use switch of course), start again the terminal, and choose competition srs.

    Rescue mode was invoked, and successfully rescued the unit.

    Several times.

    Please try it again, and I forgot, are you using the last version of the Terminal app?

    Let me know, I will wait for your response, because that case should not happened!


    many thanks

    rudi

  • hello Alain and all,


    I spent several hours with testing of the new update method in new version of the Terminal. If you connect the SRS to USB adapter in compliance with recommended connections, using Y-lead, servo port connected as power supply to Y-lean, and USB adapter or BlueCom connected to Y-lead, right orientation of signal cable - down to receiver ports, then it can't happens that the update is not successful. In case, when something went wrong, and update was interrupted, broken connection, low power supply or other disasters, then the rescue mode always rescued the unit.


    Of course I tried all with the versions 24 and 28:

    1. Update from 24 to 28



    2. After not sucessfull update, always disconnect the device from power supply. Restart the Terminal app, connect all as described above and run Terminal:




    always be sure, that you are using the latest version of Terminal app! Always please check the connections, it is important.


    regards

    rudi

  • Hello Rudolf,


    I tried several times with no success with my iPhone 8, my iPad Pro and my laptop computer under W10.


    I am using the latest version of the terminal software for all devices and a Y lead to powered the bluetooth interface.

    The Apple devices are using the latest iOS.


    iPhone, bluetooth connection is OK but the terminal app quit when I tap on the Competition SRS icon or sometimes I got "No device connected"

    iPad Pro, impossible to get the bluetooth connection.

    Laptop computer, bluetooth connection is OK with the computer but terminal app does not see any bluetooth nor USB connection


    What shall I do more ?


    Best regards,


    Alain

  • Hello Alain,


    use Windows terminal now, to have info what's happened.

    1. Connect battery to Competition SRS, connect Y-lead to Tele port, also connect two wire cable (only +/-, without signal) between one servo port and one Y-lead port

    2. Connect USB Adapter to second Y-Lead connector

    3. Start Windows terminal, choose Competition SRS device, and tell me what happened. Maybe screenshot will help, also photo from the connection of SRS


    thanks

    rudi

  • Hi Richard and Rudolf,


    Similar problem. I tried to update two Competition SRS’s V0.22 to latest version V0.28. Connection was USB to computer and other end to the TELE port left side. Power to the device was from two batteries ( Powerbox 4000 mah LIPO ) and Sensor switch, PC control selected. The first device stopped at 69% and wouldn’t continue further. The SRS was powered off and disconnected from the computer. Thereafter it would not power back on, just a black screen on the SRS. With everything reconnected the computer screen showed “No Powerbox Device connected “

    The second device updated successfully. The Terminal programme was the latest Version 3.1.3

    I’ll send it to DA in Australia but would welcome your thoughts on the problem with the first device.


    Regards,


    Peter