Bluecom with igyro 3e

  • Hi. I have an Igyro3e V5 and an android bluecom with my HUWAEI mate20Pro (android 10).Used the app many times in the past with this phone Not used it for 6 months. Since yesterday I just cannot connect bluecom with 3e. I get a message in the app for No bluetooth connection. No way it can connect. Any help?

  • Oh sorry, I meant Android Terminal App, the latest version is 3.25. Attached two pictures, one with android BlueCom on android app, and second iOS BlueCom with android app. All is working smoothly, check please if you have BlueCom in list of BT devices, if it paired etc.

  • Rudolf hi

    App is the latest. I tried to bind bluecom with phone through igyro 3e but nothing. Then I tried to bind it through servo tester but bluecom cannot be found by my phone or another phone . My android bluecom Looks DEAD:P. Did nothing bad mate. Was in box since last use:|

  • hi, humm, really if BlueCom is not visible for another phone, then unfortunately is broken. Because you do not need to use App for binding and pairing. It is enough to power up the BlueCom and run Bluetooth scanner on the phone and pair it. It is independent, not app depend.



  • Hi. But also my friend's Marios Hadjikypris's bluecom doesnt communicate with App. . Both are broken while being in the box Rudolf? Doesnt seem logic to me

    Both abdroid 10 phones

    So we have to sent back for check?

  • hi, no, I thought, that your phone is unable to see BlueCom.

    Please go to Bluetooth devices, if there is BlueCom, then delete it. Power up BlueCom, does not matter if connected with some device or not, and in your iPhone go to Bluetooth devices, and pair the device. If it is working, then App must connect to the Bluecoat.


  • I am having the same problem with my BlueComm on my Samsung Note 9. I was working last month, then I put it away safely. Today it is not working. I have tried it on various PB units......

    What is going on? I have checked my Bluetooth devices and it is still paired with my phone.....???


  • Hello,

    really it is needed to check always if the BlueCom is paired. If it was paired, and you not changed the device, or not changed the settings - enable/disable, then the device persist in phone without issues. I do not know what happened, will try to simulate it, before releasing new version. If there is some error, then I will fix it, but honestly, this part was not changed for last 4 versions, in fact, half of year, therefore i'm confused!

    Will let you know soon


  • Hello,

    I tested all cases, I hope:

    1. No BlueCom in the Bluetooth devices list - starting App - paired, Blue Icon displayed immediately after pairing

    2. Two or more Bluecom units paired from the past, it can happen when somebody is using other Bluecom, will pair it - there is problem, strictly need to have only one Bluecom paired, best solution is removing all, and starting App for pairing the correct one - that's only FOR APPLE PHONES, NOT FOR ANDROID PHONES !!! In case of Android phones App allows two Bluecoms, one iOS and second Android

    3. Paired one single Bluecom - no issues, always when Blue icon appears, then all is working without issues

    4. Disabled Bluetooth - that not needed comment, nothing is working, App is pinging Bluetooth driver in the phone, Red icon is shown

    5. Enabled Bluetooth - Enabled WiFi - all okay

    6. Enabled Bluetooth - Disabled WiFi - all okay

    7. Disabled Bluetooth - does not matter what state for WiFi - see point 4

    8. Updated iOS to new version - no issue

    9. Wrong connection of the unit - opposite connection of the BlueCom - can have Blue icon, because ground pin is on signal wire and signal = 0 - ground - not working

    10. Not connected battery - not needed to comment

    If you still have problem, paste here photo of the setup/connection please.



  • Still have the same problem.

    Bluecom does not connect with mobile (android v10) and application V3.25

    I spent a lot of time to find the problem but unfortunately I did not manage to find a solution.

    Blucom paired with mobile,

    PB is in PC-Contol mode,

    Wires are connected correct,

    4G Data on my mobile are on,

    Application version is v3.25,

    Please see attached pictures

    Also some other friends have same problem.

    Could you explain us the correct procedure,in case we do something wrong.

    Many Thanks!

  • have a look on phone screen with devices - RED bluetooth icon. It means, that BlueCom ius not connected - maybe not powered on. Can't see how you connected the BlueCom. Share the detailed photo please. The icon in bottom right corner MUST be blue, if it's RED, nothing will work, the connection was not established.

  • I have connected bluecom on my powerbox Royal in TELE socket next to GPS sensor.

    (see the first picture I have attached on my previous post).

    As I know there is no need to power up the Bluecom from external source when is connected to PB Royal. Correct?

  • hello,

    for communication with any PowerBox device using BlueCom must be BlueCom connected to the phone App. This state is indicated by the BLUE Bluetooth icon in the bottom right corner of the app layout. If the icon is RED, then no connection.

    There are several possibilities why. First of all, try BlueCom connect ONLY to the battery, without any device. Then start the app, and choose one from categories. If you will not see the Blue icon, then BlueCom is not connected. Try it again, after deleting the BlueCom from the list of devices. Pair again, test if connected - blue icon.

    No connection, nothing work.

  • Hey wait one minute. I saw something strange whike trying to do all that from the begining. In a blink of an eye I saw a message appearwd for a second. What I managed to read was the words "CANNOT and IOS". I re-downliaded the app from my android phone through playstore. Is it possible the app which is in the web to fit only for IOS?? Maybe something is wrong in the app itself for androids? Coz nobody with iphone said there is a connection pb? Dont know if what i write is crap but... I dont know. Triwd severL times to make the message appear again but NOTHING

  • honestly. do not understood. From what you installed the App? What message?

    Please, complete normal installation of the App from appropriate vendor, iOS version from App Store, Android version from Google Play.

  • Dear Rudolf,

    I spent several hours today regarding this issue.

    1) With my mobile (Android v10) Bluecom paired successfully but there is no communication between application and PB Royal. Red icon was on.

    2) Then I tried with another mobile (Android v9). Bluecom paired successfully and blue icon was on. Then I clicked on Royal SRS icon to proceed with update but was not working. Nothing happened. Then tried to update iGyro SRS. Bluetooth icon was blue but no update was possible.

    3) Then I tried with another mobile (android v8).

    Bluecom paired successfully, icon was blue.

    I updated iGyro SRS successfully but Royal SRS was not possible.

    Finaly I updated Royals SRS using my PC.

    I think there is something wrong with the application and android smartphones.

    (For you info, I update PB units, for many years, for me and my friends. This time was the first time that a simple procedure became so difficult).

    Thanking you once again for your reply and support.



  • Hi Marios,

    app is tested for all Android systems from 8.1 up to X. If App not see BlueCom (RED icon), then is something wrong with the connection, power supply or something else, because powered BlueCom is always visible.

    Please do following test:

    1. take a first phone, where you was unable to setup devices

    2. power up only BlueCom - connect to BlueCom battery without any device

    3. start app and choose one from three categories, does not matter which

    If the icon will be Blue - then BlueCom is okay and paired and visible. In that case please check again your setup of BlueCom and PB device.

    please let me know the result