3e Issues following version update

  • Hi, I have my 2nd Igyro 3e and am having issues with it. I had it installed in an airframe and it worked ok but needed setting up. I connected to my laptop via the usb link and the lights on the unit worked fine. I ran the PB terminal and what I get asked is to select an update for rescue, I cant find the file to down load so I select 'online update'., It is saying the current firmware is corrupted and when I click on start update I get preparing and then nothing happens. Also since connecting and trying to complete the update as instructed the 3g has no lights working on it now?


    Can someone please give me any contact information please?


    Kind Regards

    Marc Owen

  • Hi Marc,


    It means, that you connected the iGyro to terminal and got immediately Rescue page? If so, be sure that your internet connection is okay, or choose the file, there is file named PB_iGyro_3e_V04.pbs or other, but related to iGyro 3e. Choose that file and start update. It works.

    Only wondering why you got the rescue page, there was some issue.


    please let me know if it's working

    regards

    rudi

  • Help. I connected the bluetooth module and the gyro wanted to do an update, after that the gyro is dead. When I connect it to the laptop with the usb cable it wants to do the rescue fix but nothing happens just says "processing", how long should I have to what and can I download the latest update file.

  • hi,

    I need some advice with same problem for me.

    When i connect de iGYRO3e to bluecom ask to do an update. Them after the update no lights , doesn't work, doesn't move any flight control and try to do rescue mode several times and more the one hour and nothing happen. . The app can spend 1 hour saying "Prepairing "

    Thanks