GPSII Pioneer PBR26 keeps on searching

  • GPSII sw v16 set to P2bus

    Pioneer sw v03 set to P2bus telemetry

    PBR26 sw v2.7


    GPSII is recognized so can select in the telemetry menu. Widgets are showing on the mainscreen. One of the widgets shows the status. The GPSII kerps on searching and comes never active.

    When connect the same GPSII to a single PBR26 it comes active and find satellites.

    When connected with use of a V-cable to the PBR26 and Pioneer it never comes active.

    Tried several times and installed all software twice.


    Any suggestions?

  • Hi Richard


    I currently have this problem with connecting both an iSAT and GPS II to a Pioneer via a 'Y' lead. The green lights goes solid on GPS and GPS related telemetry widgets are available but things like speed and height remain at zero, sat count remains at zero, Lat Long unknown.


    So Im guessing no data being sent from GPS.


    Dis you come up with a cable that works?


    Thanks


    Tim Jenkinson

  • Hi Richard


    So I have received the adaptor cable and installed it to connect the GPS to the Pioneer via a Y lead. It shares a Y lead with the iSAT It still does not work?


    I have checked the cable direction is correct. I have tried 2 different Y leads and two GPS units. None work.


    What am I missing here.



  • Hi Richard


    Bit difficult to photograph clearly.


    I have a single PBR26D plugged into RX1 on the pioneer using the P2BUS socket on RX.


    The iSAT and the GPSII are both plugged into a Y lead and then into the Fast Track connection on the Pioneer. I am using the cable you sent me between the GPSII and the Y lead.


    Hope this helps?

  • Hello,

    now I read it: a GPS 2 doesn´t work on the FastTrack - it must be connected to the P²-BUS of the RX1


    And place the GPS with a 50-60cm wire far away from every other electronics. Below the carbon or aluminum wing holder it will never work correctly!

  • Well this brings up an interesting conundrum; We've (my builder and I) have been messing with trying to get a GPS III sensor working with a Pioneer. My builder guy has been on the phone constantly trying to figure out what's wrong. The sensor got sent back to Power Box USA and came back with the adapter cable. It's been installed in a BVM F100D turbine with a full bypass so space in the fuselage is tight. It's also covered on top with Flite Metal.


    We've tried all sorts of locations for the sensor, the Pioneer is down on the side of the fuselage below the curve for the bye pass, The requirement for a clearnace distance of 50-60cm was never mentioned. There is no way that kind of distance could be obtained in this model if by "electronics" you include batteries. I know that placing the sensor on top of the instrument panel produced no lock.


    I have three Pioneers, two earlier ones with one having the Ver 3 firmware, the second with Ver 4 and despite updating those units and using the adapter cables from PB USA, we cannot make either of them work out on the porch let alone in a model. The third Pioneer has the green dot on the back, another revelation from PB USA..... It is the ONLY ONE OF THE THREE WE CAN MAKE LOCK ONTO THE SATELLITES WHILE ON THE PORCH.


    It's going into a BVM 1:5.8 F86 which also has a bye pass and tight quarters in the fuselage, we 'gotta have all that clearance from all the electronics plus batteries for that too?


    If that's the case, I want my money back.....

  • So Richard I have now done exactly what you suggest. Pioneer and GPS2 connected to P2Bus of RX1 via a 'Y' lead.


    GPS 2 placed 1m from every other bit of electronics. I have tried a normal cable and the adaptor cable you sent . Still does not work!


    Not sure where to go from here


    Cheers


    Tim J