Impossible to change the setup of SparkSwitch Pro

  • Hello!

    I wanted to set up the output voltage to the input voltage, not regulated for 5,9 V. The device is working normally in the plane. I clicked on my Terminal program in my computer. It was checking the upgrades. OK, I let run the upgrade. Upon the start of the upgraded program, it required again the upgrade. So I uninstalled the Terminal program manually and installed, from your web pages, the new one. Strange.

    However, when running the program, when I clicked on the icon of SparkSwitch Pro and waited for 10 seconds, nothing happened. Nothing. No menu to set up the switch appeared. The program, however, noticed the USB in the computer. When it was not plugged in, it reported ...no USB connected. Everything was connected according to your instructions properly.

    The SparkSwitch was previously set for a Futaba telemetry, regulated output voltage, and another channel for switching on and off the ignition. It worked normally.

    Whats wrong? Please, let me know.

    Jiri

  • hello,


    not sure what version you had previously, based on your explanation about again and again trying to update the Terminal, I think that you had V2.

    You mentioned, that manually uninstalled old version, okay, also the drivers were uninstalled? Have you had used Windows uninstaller?

    Perhaps yes. After installation of new Terminal you should see version 3.1.4:


    and no RED warning that not USB connected. If all is installed properly and connected, then please choose category Accessories, and screen above will appear.

    Then choose SparkSwitch Pro icon, you must wait 10 seconds for opening of SS control layout. After 10 sec count down will appear screen below:



    Then you can do your changes, and after that use button back to main menu and normally terminate the program.


    Hope that helps.

    regards

    rudi


    P.S.: One more thing, only for sure, because it was happened several times, that SparkSwitch was connected to USB adapter without powering up by battery. Please before you connect the USB adapter, connect fully charged max 2 cells battery to RX port, and USB adapter to Tele port.

  • Hello! Thanks a lot for a prompt reply! It works now!!! I have a lot of your devices and I highly appreciate this kind of support, indeed.

    What happened? I used the windows uninstaller, yes. I had the terminal version as you described. I did everything, you mentioned. The only thing I did wrongly was not to put the battery into the RX socket! In fact, I put it info the battery socket. I have to admit that it is also in the manual for the SparkSwitch, in the 3.3 paragraph, but it was overlooked by me. Simply, intuitively, put battery into the battery socket...

    Best regards, :):):)

    Jiri

  • I found this thread - while searching for Sparkswitch Pro USB. I JUST got my BlueCom in the mail this morning - believing that would be how I connect into my Sparkswitch Pro to manage / change settings. Yet the table in the manual indicates USB. Does that mean I can not use my Bluecom via Bluetooth?

  • BlueCom is not USB adapter. USB adapter is wired interface for Windows Terminal, and BlueCom is for Mobile Terminal App's.

    Download the MobileTerminal from appropriate shop - Apple or Android, based on your phone :-) - then put BlueCom into Tele port on the SparkSwitch Pro and put battery into RX port, and start app, choose Accessories/SparkSwitch Pro

    Cheers

    rudi

  • So I have Bluetooth working and am in process of updated my PB Comp. SRS from V25 to v28.


    I am however now having the following issue. I open the Bluecom app and connect to the SSPro i have. When i tap the icon on SSPro - it says connecting wait 9 seconds and counts down. Then nothing. Just stays on the Accessories screen - still have Blue - Bluetooth icon, but does not advance to the page in the app to allow configuration changes.

  • You're using Android App V 10, right? In that case please accept my apologies, because Google released a new patch in Android and some functionalities of special Bluetooth are blocked. We fixed that and testing now. New App version 3.26 will be released on Saturday.


    In the case of iOS App no issues.


    Thanks for the understanding

    Regards

    Rudi

  • Hi Dave,


    in that case is all working properly. Seems, you not connected battery into RX port and SparkSwitch Pro is without powering up. Please connect BlueCom into Tele port, battery (max 2 cells) into RX port and start the App, choose Accessories/SparkSwitch Pro, wait 10 seconds and do setup.


    Let me know if all is okay

    Regards

    rudi

  • only do changes and all is saved automatically during the setup. When you finish the setup, only click to back arrow left top corner, and main accessories layout appears. Then click again back and close app. Nothing is needed for some confirmation/acknowledge/save :-) All is done automatically.

    Cheers

    rudi

  • Hi,

    Her is another one, issue trying to do setups om my new SS Pro, using Powerbox terminal, just before I updated the terminal to V3.1.7

    Put the battery in "RX" marked port and USB adapter input cable in "Tele" marked port, (although manual sec 3.3 ask for a socket labeled "DATA" and a "receiver socket" could not find such labels) I click on accessory/sparkswitch Pro icon waits for countdown 10 sec but nothing happens!

    Then I try my PBS-RPM sensor and the setup procedure works fine. proves the USB adapter and terminal SW works fine.


    What could be the problem?

    /Robert

  • Hello,


    there is not reason to having issue with SparkSwitch Pro. Be sure, that you connected really the fully charged battery - 2cells - to RX port. Afterward connect the USB adapter to Tele port, also be sure that the polarity is correct, signal wire up!

    Start Terminal and choose Accessories and SparkSwitch Pro. After 10 seconds countdown will connect.


    If your issue persist, let me know, I will support you.


    have a nice evening

    rudi

  • Thanks, now it works if I follow exactly your procedure.

    connect Battery first to SS Pro then then connect USB adapter and then connect USB adapter to computer and finally start the Powerbox Terminal.

    Robert

  • Hi Robert,


    yes, really, there is no reason to have an issue if all is connected properly. Only, you do not need to connect the USB adapter to SS prior to connection to PC, I will share again the right process, the same as for other units :-) :


    1. connect the USB adapter to the PC, and start Terminal. If you will start Terminal without a USB adapter, then Terminal is going to offline mode, usable for programming of Core or using Analyzer

    2. The connect the battery, really good to have a fully charged battery, to the unit.

    3. After connecting the battery to the unit - powering up the unit - connect the USB adapter to the unit. That's an important step, please do not connect the USB adapter to the unit without powered up the unit - step 2 - unit can't be powered up by the adapter

    4. And now you can choose the unit from the menu in Terminal and start programming


    When you want to update the unit with new firmware, please never interrupt the process. Terminal avoids you from closing the Update process, even you can stop Terminal or disconnect the device, and that causes big issues in case of updating of units.

    Anyway, in that case, of a broken update process, still you are able to Rescue the unit. For the Rescue, you have to disconnect all, again connect all, and starting the programming. The terminal will show the Rescue layer with the option to choose the software from internet or file, the same as in case of Update. Do it, and the unit will be again able to communicate.


    have a great day

    rudi