igyro update failure.

  • Hello Richard.

    My I gyro v 25 seems not working properly.


    During update process to v28 with usb terminal. everything looks working but when I push start update button. Igyro reboot and termninal page stuck ant 'preparing'.

    so I aborted update and try use it but no digital out put and pwm out put neither. all those function with reciever works. I can see the flight mode change follows tx signal so on. but not output.


    I tried factory reset. and tried with bluecom. but no success.

    I gyro's display looks O.K , respond to switch O.K . entering PC control O.K... terminal show me current version is V25 . when I push update button. IGyro seems reboot. and nothing happens and display show me Igyro status... temp ----- flght mode 1 gps no sensor sensors: blank.

    at this situation. I can not acsess to recue mode since I gyro boot normally.


    Any Idea?


    Regards

    Park

  • Hello,


    yes, if iGyro is normally responding then no rescue, but update again. Please disconnect all from iGyro, only power up, connect usb adapter cable, start terminal and update again. Do not break the update process please, or, if you will break the process, then rescue mode will help :-)


    let me know if you will have some further problems

    rudi

  • How can I rescue igyro srs with PC or bluecom? mobile terrninal say 'only update availlable'.

    now I have 2 Igyro not working .

    THIs is really strange to me. I have 2 mercury 1 cockpit 1 pioneer and 2 Igyro.

    I updated powerbox's without any problem.

    But only Igyro having trouble.

    one got stuck in V25 the other one was V28 .. now blank screen.

  • Rescue with Terminal:

    1. Connect battery to iGyro - no other connected devices/servos/....

    2. Start Terminal and connect USB adapter to iGyro

    3. Choose category iGyro

    4. Click to iGyro SRS - wait 3 sec and Rescue mode will appear

    5. Choose rescue mode - online or from local file

    6. Click to Start

    7. Wait up to complete!


    and please be sure that you will connect all cables properly!

  • really no idea what's wrong on your side. I tried several times break the update to get blank screen - I disconnected USB from iGyro to interrupt update or disconnected battery. Always destroyed firmware.

    Then connected battery, usb or bluecom, starting app, screen black, choosing iGyro SRS, getting Rescue mode and processing rescue.


    On your photos I can see 3 wires on power supply cable, what's signal is connected? Ca you use only + and minus - two wires?

  • Hello Richard. Rudolf

    Many thanks for helping me.


    The white line in the picture is not connected to anything but just an extention from 2S life battery.

    I know igyro has kind of inverted pin location. signal on the bottom and minus will be most upper when I see the screen.


    I did my cockpit srs update without any problem just before this 2 Igyro. about 2 weeks ago I managed pioneer and igyro sat without any problem.

    I tried both I gyro with bluecom and usb terminal. Yes unfortunately I have 2 I gyro got trouble..

    1 have display working the other have blank dispaly.

    symptom is almost same. no device connected in bluecom or usb. neither on get into rescue mode.

    The old one with display working, I can entered update process to preparing but nothing happen after that.


    I am very careful with updating or make settings with powerbox product since I had hard time to trouble shooting with sbus teleconverter in past.

    I spent several hours but came out no solution.


    May be sending these 2 unit will be the only solution.