Multiple connections

  • Hello,

    I'm making the setup for a Carf Corsair. I would like to use as much telemetry capabilities as possible. I've spent 1 full day on the manuals and the forum, fut I still don't know the best way to conect the differents elements : what on what and on which plug (should I conect on the telemetry of the Royal, on the Rx, on the SparkSw, ...???). Could you make a drawing or picture of what you think is the best. I'm sure plenty of users are interested for a "global" setup. (the forum is mainly for one item at a time).

    Material I intend to use :

    -Moki 250/7 cyl.

    -Multiplex profi Tx and MPX RX16DR PRO

    -Royal SRS

    -Spark Sw Pro

    -PBS-RPM Sensor

    -PBS-250 t° sensor(on 5 of the 7 cyl)

    The information I would like to have :


    -T° of 5 cyl

    -Volts and capacity of the engine battery

    Thanks a lot for your help.

  • Hello Richard,

    not so simple indeed as I can't give addresses to the sensors. I've tryed the GPS, RPM sensor and spark swith with both the Powerbox Terminal and MPX launcher, but I've no acces. What is strange is that my 2 pc didn't detect the GPS2 on the terminal, but detect the Royal ??? Tested 3 different batteries, 2 USB adapters..

    The MPX launcher detects MPX GPS, but not the Powerbox GPS... I'm lost.

    Thanks for your help.

  • After hours of tryes, the GPS connected. It's on "royal" setting. Meaning, I've no idea of the addresses. For the RPM and Spark switch, no idea. I can't connect on any of those.

    Please let me know if I've made something wrong.


  • Hello,

    just some thoughts for your setup and installation.

    1. PowerBox Terminal Software can only handle PowerBox products.

    2. Multiplex Launcher can ony handle Multiplex Products

    3. Pls. make sure that you have the latest Multiplex Launcher and PowerBox Terminal Software in use

    4. Pls. note that it is not for sure that a Multiplex USB cable runs with PowerBox products, maybe this works maybe not.

    5. Best recommandation is use a MPX USB cable for MPX products and a PowerBox USB cable for PowerBox products

    6. Regarding the Royal setting you reach set the Royal to Multiplex then you will get the selection for the Multiplex telemetry adresse. Not sure if "Royal" setting is the right choice. Richard can advice better.

    7. Connect the Multiplex sensors with a Multiplex USB cable to the PC with a open and running Launcher Software. Important the MPX sensor needs power from a separate battery for example. A ordanairy charged 4 cell NiMh battery will do the job. Connect the sensor, battery and the MPX USB cable together via a Y cable or PB-Dock.

    8. Under the follwing video link starting at 30 seconds you can see how it looks like to change Multiplex sensor adresse inside the Launcher programm.

    MSB-2-P2B Multiplex MSB zu CORE Telemetrie Datenkonverter - YouTube



  • Hello,

    if you set the GPS to MPX in the Terminal, you can set the adresses. In the Royal you can set the addresses in the Telementry menu

    SparkSwitch: same as for the GPS, set the adresses in the Terminal.

    If you want to have so much telemetry: the Core would be the right choice ;-)

  • Hello Richard,

    I think it will work for the Royal (I used Powerbox cable and was able to conect the GPS). For the Sparkswitch, the Terminal discount the 10 sec and says connect, but nothing happens (with the terminal and the Bluetouth).

    Of course the Core.... but a little out of my budjet for now and Santa forgot me ;o((

    Edited once, last by leclercqr: Hello Richard, you finally bite me ... I've ordered my Core (MPX) Just a question I did'nt found the answer on the forum. I've several models with Competition, Royal, ... flying wint the MPX . Should I make new setups in thoses boxes with the Core or everything should be ok? Thanks ().

  • Hello,

    I've spent a complete afternoon on the telemetry. The GPS problem is solved.

    For the 3 other sensors (Sparkswitch, RPM-Pickup and PBS-250 : The pc terminal don't see them (no Powerbox connected)witha brain new Powerbox adapter.

    With the Bluetooth terminal, the app conts from 10 to 0 sec, "connecting" ... and nothing. With the PBS-250, the app crashes and close.

    I tryed to put those sensors directly on the telemetry port of my MPX receiver, but no contact....

    You say in the manuals that those sensors are adapter for M-Link, but I would like to know the procedure to make them detected and assign an address.

    Thanks for your help.

  • The terminal don't detect those sensors, they are not on the screen.(I just made your procedure 3 times)

    For the BlueCom, The phone find it, in accessories, I click on the sensor, "waiting for 10->0 sec, connecting... and nothing. The PBS250 crashes the app. On the settings of the phone (Samsung A70) I see the BlueCom, but it is not connected.

  • Next update:

    The blue com see the Sparkswitch which is on M-Link, but no way to assign an address.I put it on the MPX Multimate to try, but not seen.

    The RPM-Pickup is not on the list of accessories, and the PBS-RPM don't see it.

    The PBS-250 crashes the app.

    The GPS3 is seen by the app and is on Royal.... I have speed/alt datas on my transmitter after assigning the addresses in the Royal.

    3 sensors I can't use and I don't understand why.

  • Hello,

    - You cannot set the Adress with your Multipmate - it´s a PowerBox product not a Multiplex

    - The RPM Pickup is not a sensor, it is used as a RPB detector connected to the SparkSwitch

    - We will check

    - ok, good so far.

  • Hello,

    I can't imagine what you meant with "they are not on the screen.(I just made your procedure 3 times)". In category Accessories you are unable to see those sensors? May I ask you for screenshot or photo of the screen?




  • Hello,

    on the PowerBox Terminal, there is no (I don't see) the accessories .See pictures. I'm trying to update the app, but it's not working. I will remove it from my pc and retry.

    Best regards


  • Hello,

    you are right, that was the problem. The "auto update" on the pc is not working. Then I removed the app completely and reinstalled it from scratch ... and It works perfectly ;o)))) . Then, I made the same process on my mobile. The problem is partially solved: the PBS-250 is working now, I've full acces on the addresses. For the Sparswitch, it's the same problem. In M-Link, the page shows only the volt limitation, but no addresses choice.

    Thanks for your help.

    I was sure that it will work, I'm using Powerbox products since very long time and it always work ;o))