Posts by cespedes

    Hello,


    I read that the Mercury does not show each of the battery capacities on the OLED, like the Royal does, but does it stream it via the teleconverter (telemetry) to the radio?


    The OLED screen is kind of small so I get they can't cram everything on the screen, but I suspect it is still keeping track of the values, or is it not at all?


    Thanks in advance.


    sc

    Hello Alexander, Richard,


    I'm glad to hear you received the unit and that you determined what is wrong with it. Could a bad servo cause this? Can you determine which servo port on the PB this happened on? I can try and look at my setup. I'm glad it is not a big problem, and as usual, thank you for the excellent support.

    Hi Richard,


    I'm sorry, I don't think I was clear, I am not requesting a advance replacement. What I was asking is if it could be replaced by Gerhard when I send him this unit instead of waiting for the unit to be sent to Germany. I don't feel comfortable flying the plane if the PB is malfunctioning, the model is very expensive. LMK.

    ok, I was hoping this wasn't the case, the PB is built into the model and will be a lot of work to remove. It is also late in the season, I bought the unit from Gerhard, would it be acceptable to send this unit to him and have him send me a replacement? It's less than a year old. I hope you find that acceptable. LMK.


    sc

    Richard,


    I understand what you mean about this not being a typical error, I have several Royals & have been running some of them for years, and have never seen this before either. The unit shows a value on I-out, V-out A and V-out B, when I disconnect either battery the unit continues to operate. The only issue is the left side battery voltage display shows 0.0, the right side shows a voltage. When I swap the batteries between sockets, it shows the new batteries voltage on the right, the left side is still 0.0 volts. Also, the bar graph is not filled in on the left side, the right side shows output and min value. If I go to the Power-Flight Recorder screen Batt 1 shows a low number for the min voltage and max current values, there is also minimal consumption increments, like 1 mAh every min or so, the right side shows correct values for Batt2. Batt 2 seems to be the only battery being used by the unit for some reason. thoughts?

    Hello Richard,


    I upgraded my Royal SRS from 10.4 to 12.4 last night, and I'm now seeing zero volts on the V-batt 1. I tried swapping the batteries from socket batt2 to socket batt-1 and vice versa but it doesn't make a difference, zero volts on V-batt 1 on telemetry and on the screen. Any thoughts on what could be going on? Have you seen this before? Should I try to downgrade the unit?


    I hope to hear back soon, thanks in advance for your support.


    sc

    Hello Richard,


    I've been testing the Gemini II and I've noticed that when I am turning the system off with the magnet the unit sometimes appears to restart instead of shutoff. Sometimes it just emits the audible tones but the power is not shut down at all, and other times it looks like it's rebooting. Why would this be occurring?


    thanks in advance.


    sc

    Hello Richard,


    The batteries I have connected to a Gemini II have multiple leads. Can I charge the two batteries on the secondary leads while the primary leads are still connected to the Gemini?



    Battery Detail:
    Type: 2s LifePo
    2 batteries
    each has a balance port
    each has 2 separate power leads


    Regards,


    sc

    Hello Richard,


    I am programing a new iGyro SRS & I'd like to use the (2) DIG-OUT ports (Ele-B & Rud) connected to a BUS system, but I would also like to continue to use the remaining ports (Ail-A, Ail-B & Ele-A) as analog ports. It appears the analog ports are disabled when I enable the DIG-OUT setting. Is there a way to use both?


    Regards,


    sc

    Hello,


    I use PBox batteries exclusively, I'd like to begin to use PBox batteries to run my turbines as well. In order to properly dimension or select the right battery I need to know the C rating for both the 2800 and 4000 batteries.


    Thank you in advance.


    sc