Posts by cespedes

    The R7008 works on my other Royal SRS, but it's in an other model. I have not tried the r7007 on this pbox unit. Do you think it could have something to do with the verrsion of code on this pbox? It's running v8.4.


    sc

    Hello Richard,


    I hope all is well. I'm building a new jet and I am using Futaba R7003s RXs instead of R7008s, as I had used on my previous builds with no issues. The issue I'm having is that the powerbox only seems to recognize the RXs when connected to the sbus.2 port, port 3. I'm also trying to use that port for the teleconverter, which is working fine, but according to the manual I should be using a sbus por. Port 1 should be sbus based on the mode I'm using. I've double checked the mode and I'm in mode 1 it to make sure, any thoughts?


    The display does not show a solid RX led for the RXs unless I use port3, the sbus2 port. Let me know.


    sc

    I have it working on the 14SG, I don't see how the 18SG would be limited. From the looks of it, it's a upgraded 14SG with more channels and touch-screen.

    I just re-read the Teleconverter installation instructions, I think I may have to go back and change the operating mode from CURR-1678 to Powerbox on the sensor. Let me know if you agree.


    Snip from instructions:
    Depending on the mode in which the Teleconverter is operated, you will find Current sensor (CURR-1678) or PowerBox Sensor in the Sensor List.

    I got it installed but I'm not getting telemetry on that sensor. I tried to change IDs with the "current1" sensor and resetting the sensors. Do we need an update on the PB side?


    We got the following:
    volt bat 1 & 2
    cap bat 1 & 2
    rx fade 1 & 2
    hold
    speed
    altitude
    trip
    distance
    lost frame


    sc

    Hello,


    Could you please recommend the appropriate size battery to use as the main starter battery for a Jetcat P180rx turbine? The turbine comes with a LiPO or Life battery but I'd prefer to use PB LiPOs. Thanks in advance.


    p.s, my preference would be 2800 due to the tri-color LED but would manage if it needs to be a 4K, let me know.


    sc

    Hi Richard,


    Thank you, I appreciate the continued support. It's fantastic news, do you happen to have any time frames? And please let me know if you're interested in any field trials, I'm glad to set it up and test it on my end, I'd pay for the sensor. I'm not looking for a free-bee, just looking to help in the development of a end result.

    Hello,


    Is there a way to connect an external LED, or two, to the fuselage to help show the status of the MAG Sensor switch? The way the MAG Sensor is built it makes it difficult to install it in a way where the two LEDs on the switch are visible from the outside of the fuselage. Thanks in advance.

    Very disappointing that the 14SG is not going to support the PB sensor. Even though I own a Royal SRS with GPS II, I'm not even that interested in the GPS details. Is there a possibility of installing two of these sensors to try and add the telemetry for the second battery?


    Can you somehow help with a workaround to help us non-18MZ radio owners? I think we would settle for capacity and voltage for each battery, current and everything else would be nice but not critical. Is there anything you can help us with? Thank you in advance and happy holidays.


    sc

    Hello,


    Is there a way to get to the gyro "set correct gyro direction" menu in the Royal SRS without having to go through the gyro basic setup screens?


    thank you


    sc

    Let me try that, I like using the channel match function simply to set center and endpoints, is this ok? Even though I don't need to match to an other servo? I decided to do this in order to centralize all of the config in the pbox and not a mix between the radio and pbox. let me know your thoughts.


    sc

    Hello,


    I am performing the final provisioning of the system and i am trying to use the pbox to configure the center and endpoints on the throttle output port/servo. When ever i try to initialize it, I get the window stating, "I need to initialize the channel first". I've already matches several channels for the elevator, rudder and ailerons, so I'm familiar with the process, I'm wondering why it won't allow me to do it on direct 3.


    sc

    Hello,


    Can the available safety clips be used on connections to the powerbus adapters? For example, the connections to the powerbus to bus or the powerbus splitter? The connections do not appear as if it should come apart, but I'd prefer to use what is available.


    also, what is everyone else using, if not the safety clip? Thank you in advance.


    sc

    I tested on RX 1 and I am now getting Voltage and capacity, but not current values. what happens if we were to lose RX1, we also lose telemetry I suppose?


    Do we have any details on when Futaba will support the Powerbox sensor? They just released v5 for the 14sg, does this include support?


    sc

    Hi,


    When I go into the rx/telemetry menu screen. I only see options for chemistry, capacity, output voltage a/b, but no "TELEMETRY SYSTEM" as is stated in the manual. I'm using a 14sg, and I have the teleconverter installed, I have no data.


    Also, does the teleconverter need to be plugged into RX 1 or can it be plugged into 1 or 2.


    sc