Posts by Cyclovinc

    Hello,


    This weekend my pump stop working after only 3L of smoke oil Blue Max running in it

    The electronic seems to be ok because the LED and "sound" programming are still working but the pump is not running

    Any idea to fix the problem ?


    Thanks


    Vincent

    Hello Richard,


    A question regarding the battery:
    Can I connect battery with two different capacity ? I have a 3000mA and a 2500mA 2s lipos in my stock..
    Another question, when the Gemini II is OFF do you have a "leak" current that could empty the lipos if connected ?


    Thanks


    Vincent

    Hello,


    Thanks for your support, now it is working ;)
    May I suggest you to indicate in the instruction Manuel that minimum 2 satellites are mandatory
    The manual say "up to three satellite receivers can be connected" for my understanding it does not mean that minimum 2 are required


    Regards


    Vincent

    Hi all,


    I just came back from jetPower with my new Igyro and I'm scratching my head to make it work with my spectrum system


    My transmitter is a DX 18
    my receiver system is a power box Evolution (not SRS) with a DSM 2 spectrum
    I have connect my Evolution between the Igyro and the servos that will be control by the Igyro, so to summarize:
    I gyro elevator, rudder and aileron connections are going to the input of the Evolution and the outputs of the Evolution are going to the servos. is it correct ?


    the binding sequence seems to work but after it I have no control to the servos and the Igyro does not detect the fly mode switch ?


    my Igyro is V21


    1. In the binding menu I have DSMX and DSM18K ?? Should I use this option for my transmitter DX18 ?
    2. The GPS is connected and the green Led is On but the Igyro indicate "NO SENSOR" ?
    3. Do I need to connect more than 1 satellite to the Igyro ?


    Thanks a lot for your answers...I'm lost and I don't know what to do


    Vincent Belgium