Posts by Cazador

    Hello!


    You need press both buttons, then switch on the PB Pionner, the orange LEDs will start blinking.


    Other thing, I am using a Spektrum NX10, (but I think that in IX12 it should be the same), remember to go to Serial Port Setup in your TX, and activate Serial Port Protocol to SRXL2.


    BR, Federico.-

    Hello Richard,


    Thanks for your support and help.


    I agree with you. I think there is too much flow and I cannot control it. I've spent the whole summer trying to fix this to no avail.


    I have made a mistake when buying the pump, I will buy the other model. 8)


    I have friends who fly jet, surely someone will be interested in my smoke pump. ;)


    Great support!, thank you a lot! :thumbup:


    Cheers from Switzerland, Federico.-

    Hello Richard,


    thank you for your reply.


    I have tried lowering to the minimum possible, but if I go too low, the pump does not smoke, so I wonder if where I have installed the pump is okay.

    These last few months I have tried to adjust the pump, but without favorable results. ;(;(


    If I install longer tubes between the pump and the muffler, could it work?


    Thank you for your help.


    Regards, Federico.- 8)

    Hello!


    A few years ago I bought a Jet version smoke pump.

    I have installed it on a 106 "Edge, on the firewall right next to the engine.

    Currently the pump works very well, and I have no problems with it.

    The problem I have is that when I switch off the pump from the radio, the smoke keeps coming out of the exhaust, in other words, there is an excess of smoke fluid in the exhaust.

    If I decrease the flow of the liquid, the smoke does not work.

    The liquid I use is the Powerbox Smoke Oil Blue Max


    I wonder if:

    • It is correct where I have installed the pump (see picture).
    • The Jet version can be used in a 3D plane with a DA-120.
    • I need to use some valves to control the flow.


    I would appreciate your help. :thumbup:


    Regards, Federico.- 8)

    Hello Richard,


    Thanks for your quick response.


    I have tried to charge the pack that works 8.11V and I can charge it. Using the same cables, in the pack with 7.73V, the charger gives me an error.


    Anyway, I will try to fly tomorrow, I will try to charge the batteries again.


    Best regards, Federico.- :)

    Hello,


    I have a problem with a Power Pak 2.5 X2 ECO.


    Today I wanted to charge the Power Pak, the first one charged without problems. But in the second, the charger indicates the following error:

    • Connection error. Check main port.

    I have connected them to my power box, and the voltages are as follows:

    • 7.73V --> Defect pack
    • 8.11 --> Good pack

    The pack have only 2 flights.


    What could be the problem?


    Thank you.


    Regards, Federico.- 8)

    Hello!


    First, Happy New Year everyone! :thumbup:


    I have a Powerbox Evolution Spektrum installed on a plane, and I would like to use the batteries PowerPak 2.5 which I am using in my PowerBox Competition SRS.


    Reading the manual of my Evolution Spektrum, the type of batteries supported are LiPo, NiCd / NiMH and LiFe.


    If I want to use the PowerPack (these are LiIon batteries), what type of battery should I select in the Powerbox Evolution?


    Thank you for your support.


    Best regards, Federico.- 8)

    Hello,


    My name is Federico from Switzerland.

    I'm currently building a plane for 3D Aerobatic (3DHS 106").

    I plan to install your smoke pump, and I wanted to know if I can connect it directly to the PowerBox [Competition SRS] and I would like to use the same batteries for power the entire systems.

    I bought 2 x PowerPak2.5X2 ECO to power the plane.


    Thank you a lot for your help and support. :thumbup:


    Best regards, Federico.-