Posts by Pascal Rousseau

    Hello Richard,


    Continuation of my tests.

    I moved the GPS III far away from any electronics or cables in the nose of the plane.

    I still have the same problems with both GPS IIIs.


    Attached is a data record.

    Orange cells = frozen speed data

    Red cells = loss of data and bad GPS coordinates.


    I have absolutely no confidence in flying with the GPS III.

    If the Mercury receives the wrong speed indication, there is a risk that the gyro gain will not be reduced at high speed with my jet.


    I will return the GPS IIIs to you for repair or replacement.


    Flight GPS III.zip

    Hello,


    The GPS is installed under the canopy. Attached is the photo of the installation.

    I have a second new GPS III for another aircraft.

    Before I send this one back to you for replacement, I'll test the second one to see if the problem is the same.


    Hello Richard,


    I bought a GPS III to replace a GPS II with which I occasionally lost data.

    The GPS III is supposed to be more precise.

    The GPS is installed on a Mercury powerbox.

    Attached are two examples of Data logs recorded with Futaba telemetry on the same model and at the same position.

    With the GPS III it is worse and the loss of data is almost permanent.


    Is it due to a product defect?

    Is the mercury gyro affected by the loss of speed data?


    Best regards.

    Pascal


    Data logs GPS.zip

    Hi Richard,


    I updated GPS II to V 0.1.6 and now it works.

    I receive the GPS coordinates.


    The only small problem is that in the log file the coordinates of Latitude and Longitude are inverted.


    When I import the log file to create a .KMZ for Google Earth, I need to swap the coordinate columns.

    Hello,


    I use a teleconverter with my Futaba T32 for telemetry datas from Powerbox Mercury with GPS II.

    Powerbox sensor is set from slot 16.


    I receive all the datas, expect the GPS latitude and longitude.


    - Battery voltage 1 and 2: OK

    - Residual capacity: No but not suppported by Mercury

    - Number of Fades, lost Frames, Fail safe: OK

    - 3D speed: OK

    - Altitude: OK

    - 3D distance: OK

    - Distance covered: OK


    - GPS positional data (latitude and longiture): NO

    Not shown on screen and not recorded in the datas log.


    Any idea to solve the problem?


    Best regards.

    Hello Richard,


    All functions are now set "Hold" in the transmitter and Battery Failsafe (B.F/S) is off.


    Now, it works.


    Maybe, it is an additional information for the next Champion SRS Manual update.


    Thanks for your help.


    Pascal.

    Hello Richard,


    I just finished the installation of the new Champion SRS on my new plane.
    I use Futaba T14 and 2 SBUS Futaba RX.


    I have a trouble with the fail safe/hold function :
    I have set all output functions on hold, exept throttle output on Fail safe position.
    Teach failsafe position is done.


    When I turn off the transmitter, all the outputs moves immediately to the set or hold position = OK
    But 2 seconds after all the outputs goes to the the maximum servos travel !! (over the end points)
    Then, after 1 second the outputs moves back to set or hold positions.


    Do you have an idea of the reason of this trouble ?


    Best regards.
    Pascal.