No Fail safe with Expander

  • Hi There,

    This is my first time using these forums. I apologise in advance if I have committed an error where or how I have entered it.

    My problem is with Failsafe and the Expander. (I think) The use of the Expander was to enable two Rx's to meet the NZ regs. But, I cannot get Failsafe to work with it.

    My setup:

    Powerbox Expander

    Futaba T14SG Tx,

    2 x R7003SB Rx's

    A mixture of analog and digital servos

    Same type of servo in each wing via separate channels 1 & 7 (by program mixing)

    2 servos ganged together of the same type for the elevator on separate channels 2 & 10 (by program mixing)

    1 servo on the throttle Channel 3

    2 x 6volt battery packs through a redundancy switch with 2 leads into 2 separate channels in the Expander. **I have not used the MPX port.

    I use the Bluecom module and iphone 6S to program the Expander.

    Also program mixing elevator/flap. The other model is twin engine so, program mixing the separate engine channels.

    Each Rx connection is from Port 1 to RX1 and RX2 in the Expander. I have used all channels 1 to 12 on the Expander.

    **I have 2 aircraft setup like this except (not same type of model) one of them, the 2 x 6 volt battery packs go through a redundancy switch to the MPX port. Apart from that, they are identical in setup.

    Both have the same Failsafe problem (won't work).

    On other models where I have not had a need for the Expander, I have used the Failsafe procedure as laid out in the Futaba manual, and it works as it should.

    Procedure:

    With Bluecom plugged into Rx and switched on, Tx switched on I upgraded the module to V3.16 and the Expander to V4. It was already set to S-bus with a frame rate of 15ms. Rx switched off after completion.

    Next, I entered the throttle, elevator, and ailerons all together in the Tx failsafe window by applying the amount of preset control wanted and holding the % button to set for each of the controls.

    Switched the Rx on again with the module in place and with my iphone selected Powerbox Systems then Powerbox Expander. In the Failsafe window, ticked the Failsafe buttons for:

    1, 2, 3, 7, & 10 and left the rest on hold. Next, I pushed the 'Teach Me' button. Apart from a slight dimming of the 'Teach Me' button, there was no other indication that anything had worked.

    Turning the Tx off, the only channel that worked was the throttle. Nothing else.

    I tried various other combinations, and still nothing. Searched the internet, read through the threads in this forum. Nothing.

    I hope you can help me.

    Thank you.

    Dennis Clark

  • Hello,

    the procedure is:


    - Bring all sticks and switches at the radio in the failsafe position, RX/TX on

    - No failsafe settings in the radio!

    - Connect the BlueCom (latest version) and go into the Expamder settings

    - Activate Failsafe at the outputs you want

    - Click teach failsafe

  • Bingo! Thanks Richard. That was so simple in the end.

    I went back over the instructions to see why I didn't pick it up. I think its just the difference in terminology.


    I did learn, that all the channels needed, have to held in position together when 'Teach Me' is pressed. Else, the ones missed will not be Failsafed.


    Thanks.

    Cheers

    Dennis