GPSIII signal failure - Mercury SRS

  • Hello,

    I just bought a GPSIII. This one is connected on the Gps port of the Mercury SRS (the bluecom shows the ygyro/royal is selected). A teleconverter is connected from the box, to the RX 7006SB on the SBUS2. After more than one hour, the green light is still slowly blinking. The powerbox sensor is connected on slot 8 and i receive the basic telemetry (Volt, cap etc). Distance, speed, altitude show 0 and don't change. All the procedure is done in my garden, and the GPS is far enough from electric cables/devices. So what do you suggest me to do with this GPS to make it work?

    Thank you for your help.

    Wilfried

  • The GPS was outside the plane at this the moment.

    But now, i even can't connect it on the bluecom, and isn't recognized on the power box 'screen! GPS: - !! The LED is flashing twice when it's connected, on the box or on the bluecom or on this SBUS2 port.

    I tried to connect it directly on th RX SBUS2... still nothing. I've some other houses around my garden but not that much.Then I tried to connect an old GPSII... it works. Unfortunately, i think this GPSIII is out of control.

  • Hi there ! I have a good news for you.

    My GPSIII is now working.

    As Richard said, "If it flashes twice it is not connected to the bluecom - then it has already satellites and the system was detected".

    So i connected the GPS with usb cable. (on one of my computer this cable is not recognised, so i used another computer that detected the usb cable). Then i read "current firmware: corrupted". So i had to update once more the new firmware.

    Then, in order to make a short test, i connected the GPS directly on a 7008SB, and the light appeared fix green after 30 sec. Perfect. So then i connected the GPS on my powerbox mercury which is installed in my plane. After 20mn, the fix green light appeared. A bit long probably because of some houses around me. A telemetry check on my radio shows that the distance is increased when i walk in my garden. So that means that the GPSIII is working perfectly at this moment.

    I hope this will help some others of you ;)

    A special thank to Richard and some other friends.

  • Hello

    Yes i updated it before using the bluecom. But i noticed nothing that could be wrong. I guess the GPS was corrupted after this update, due to a bad connexion between my phone and the bluecom. Anyway, now all is ok with this GPSIII but i have to check it at the airfield to mesure the time to get satellites... 20mn in my garden.

    Have a nice day !